ZOJ 1372 Networking

题目链接:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemCode=1372

Networking

Time Limit: 2 Seconds      Memory Limit: 65536 KB

You are assigned to design network connections between certain points in a wide area. You are given a set of points in the area, and a set of possible routes for the cables that may connect pairs of points. For each possible route between two points, you are given the length of the cable that is needed to connect the points over that route. Note that there may exist many possible routes between two given points. It is assumed that the given possible routes connect (directly or indirectly) each two points in the area.

Your task is to design the network for the area, so that there is a connection (direct or indirect) between every two points (i.e., all the points are interconnected, but not necessarily by a direct cable), and that the total length of the used cable is minimal.


Input

The input file consists of a number of data sets. Each data set defines one required network. The first line of the set contains two integers: the first defines the number P of the given points, and the second the number R of given routes between the points. The following R lines define the given routes between the points, each giving three integer numbers: the first two numbers identify the points, and the third gives the length of the route. The numbers are separated with white spaces. A data set giving only one number P=0 denotes the end of the input. The data sets are separated with an empty line.

The maximal number of points is 50. The maximal length of a given route is 100. The number of possible routes is unlimited. The nodes are identified with integers between 1 and P (inclusive). The routes between two points i and j may be given as i j or as j i.


Output

For each data set, print one number on a separate line that gives the total length of the cable used for the entire designed network.


Sample Input

1 0

2 3
1 2 37
2 1 17
1 2 68

3 7
1 2 19
2 3 11
3 1 7
1 3 5
2 3 89
3 1 91
1 2 32

5 7
1 2 5
2 3 7
2 4 8
4 5 11
3 5 10
1 5 6
4 2 12

0


Sample Output

0
17
16
26

 题意:设计网络链接中的一些地点。给定这些区域中的一些点,以及这些点之间可以用网线链接的线路。对每条线路,给定了连接两个地方所需网线的长度。使得该区域所有地点链接,并且是线路最短。

分析:最小生成树

AC代码:

#include <iostream>
#include <algorithm>
#include <cstdio>
using namespace std;
const int N=10000;
struct node{
    int u,v,d;
}q[N];
int n,m;
int pre[N];
void init(){
    for(int i=1;i<=n;i++){
        pre[i]=i;
    }
}
int Find(int x){
    if(x!=pre[x]) pre[x]=Find(pre[x]);
    return pre[x];
}
void join(int x,int y){
    int tx=Find(x);
    int ty=Find(y);
    if(tx!=ty){
        pre[ty]=tx;
    }
}
bool cmp(node a,node b){
    return a.d<b.d;
}
int Kru(){
    int ans=0;
    sort(q+1,q+1+m,cmp);
    for(int i=1;i<=m;i++){
        if(Find(q[i].u)!=Find(q[i].v)){
            join(q[i].u,q[i].v);
            ans+=q[i].d;
        }
    }
    return ans;
}
int main(){
    int a,b;
    while(scanf("%d",&n)&&n){
        scanf("%d",&m);
        init();
        for(int i=1;i<=m;i++){
            scanf("%d%d%d",&q[i].u,&q[i].v,&q[i].d);
            if(q[i].u>q[i].v) swap(q[i].u,q[i].v);
        }
        int ans=Kru();

        printf("%d\n",ans);
    }
    return 0;
}

 

posted on 2018-09-26 15:19  坤sir  阅读(140)  评论(0编辑  收藏  举报

导航