ZOJ 1406 Jungle Roads

题目链接:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemCode=1406

Jungle Roads

Time Limit: 2 Seconds      Memory Limit: 65536 KB

The Head Elder of the tropical island of Lagrishan has a problem. A burst of foreign aid money was spent on extra roads between villages some years ago. But the jungle overtakes roads relentlessly, so the large road network is too expensive to maintain. The Council of Elders must choose to stop maintaining some roads. The map above on the left shows all the roads in use now and the cost in aacms per month to maintain them. Of course there needs to be some way to get between all the villages on maintained roads, even if the route is not as short as before. The Chief Elder would like to tell the Council of Elders what would be the smallest amount they could spend in aacms per month to maintain roads that would connect all the villages. The villages are labeled A through I in the maps above. The map on the right shows the roads that could be maintained most cheaply, for 216 aacms per month. Your task is to write a program that will solve such problems.

The input consists of one to 100 data sets, followed by a final line containing only 0. Each data set starts with a line containing only a number n, which is the number of villages, 1 < n < 27, and the villages are labeled with the first n letters of the alphabet, capitalized. Each data set is completed with n-1 lines that start with village labels in alphabetical order. There is no line for the last village. Each line for a village starts with the village label followed by a number, k, of roads from this village to villages with labels later in the alphabet. If k is greater than 0, the line continues with data for each of the k roads. The data for each road is the village label for the other end of the road followed by the monthly maintenance cost in aacms for the road. Maintenance costs will be positive integers less than 100. All data fields in the row are separated by single blanks. The road network will always allow travel between all the villages. The network will never have more than 75 roads. No village will have more than 15 roads going to other villages (before or after in the alphabet). In the sample input below, the first data set goes with the map above.

The output is one integer per line for each data set: the minimum cost in aacms per month to maintain a road system that connect all the villages. Caution: A brute force solution that examines every possible set of roads will not finish within the one minute time limit.


Sample Input

9
A 2 B 12 I 25
B 3 C 10 H 40 I 8
C 2 D 18 G 55
D 1 E 44
E 2 F 60 G 38
F 0
G 1 H 35
H 1 I 35
3
A 2 B 10 C 40
B 1 C 20
0


Sample Output

216
30

题意:村子用大写字母表示,不超过26个村子,每行第一个字母表示这个村,后面数字表示跟其他村有多少道路连接,后面的字母表示道路连接到的村子,数字表示维护道路的路费。要找出链接所有村子,且花费维护道路花费最少的费用。

分析:最小生成树

AC代码:

#include <iostream>
#include <cstdio>
#include <algorithm>
using namespace std;
const int N=10000;
struct node {
    int u,v,d;
}q[N];
int n,cnt;
int pre[N];
void init(){
    for(int i=1;i<=26;i++){
        pre[i]=i;
    }
}
int Find(int x){
    if(x!=pre[x]) pre[x]=Find(pre[x]);
    return pre[x];
}
void join(int x,int y){
    int tx=Find(x);
    int ty=Find(y);
    if(tx!=ty){
        pre[ty]=tx;
    }
}
bool cmp(node a,node b){
    return a.d<b.d;
}
int Kru(){
    int ans=0;
    sort(q,q+cnt,cmp);
    for(int i=0;i<cnt;i++){
        if(Find(q[i].u)!=Find(q[i].v)){
            join(q[i].u,q[i].v);
            ans+=q[i].d;
        }
    }
    return ans;
}
int main(){
    std::ios::sync_with_stdio(false);
    while(cin>>n&&n){
        char ch,ch1;
        int t,t1;
        cnt=0;
        init();
        for(int i=1;i<=n-1;i++){
            cin>>ch>>t;
            for(int j=1;j<=t;j++){
                cin>>ch1>>t1;
                q[cnt].u=i;
                q[cnt].v=ch1-'A'+1;
                q[cnt++].d=t1;
            }
        }

        int ans=Kru();
        cout<<ans<<endl;
    }
    return 0;
}
View Code

 

posted on 2018-09-26 15:02  坤sir  阅读(159)  评论(0编辑  收藏  举报

导航