HDU 1079 Calendar Game(简单博弈)

Calendar Game

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1871    Accepted Submission(s): 1065


Problem Description
Adam and Eve enter this year’s ACM International Collegiate Programming Contest. Last night, they played the Calendar Game, in celebration of this contest. This game consists of the dates from January 1, 1900 to November 4, 2001, the contest day. The game starts by randomly choosing a date from this interval. Then, the players, Adam and Eve, make moves in their turn with Adam moving first: Adam, Eve, Adam, Eve, etc. There is only one rule for moves and it is simple: from a current date, a player in his/her turn can move either to the next calendar date or the same day of the next month. When the next month does not have the same day, the player moves only to the next calendar date. For example, from December 19, 1924, you can move either to December 20, 1924, the next calendar date, or January 19, 1925, the same day of the next month. From January 31 2001, however, you can move only to February 1, 2001, because February 31, 2001 is invalid. 

A player wins the game when he/she exactly reaches the date of November 4, 2001. If a player moves to a date after November 4, 2001, he/she looses the game. 

Write a program that decides whether, given an initial date, Adam, the first mover, has a winning strategy. 

For this game, you need to identify leap years, where February has 29 days. In the Gregorian calendar, leap years occur in years exactly divisible by four. So, 1993, 1994, and 1995 are not leap years, while 1992 and 1996 are leap years. Additionally, the years ending with 00 are leap years only if they are divisible by 400. So, 1700, 1800, 1900, 2100, and 2200 are not leap years, while 1600, 2000, and 2400 are leap years.
 

 

Input
The input consists of T test cases. The number of test cases (T) is given in the first line of the input. Each test case is written in a line and corresponds to an initial date. The three integers in a line, YYYY MM DD, represent the date of the DD-th day of MM-th month in the year of YYYY. Remember that initial dates are randomly chosen from the interval between January 1, 1900 and November 4, 2001. 
 

 

Output
Print exactly one line for each test case. The line should contain the answer "YES" or "NO" to the question of whether Adam has a winning strategy against Eve. Since we have T test cases, your program should output totally T lines of "YES" or "NO". 
 

 

Sample Input
3 2001 11 3 2001 11 2 2001 10 3
 

 

Sample Output
YES NO NO
 

 

Source

 

这题就是很简单的博弈题目。

一天一天分析,可以发现,(天数+月份)是偶数时胜的,奇数为负的。但是有两个特殊的是9月30和11月30,这两个也是胜的。

分析的时候,只要一个一个月去看。就可以很容易得到上述的结论。

#include <string.h>
#include <stdio.h>
#include <algorithm>
#include <iostream>
using namespace std;
int main()
{
    int y,m,d;
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d%d",&y,&m,&d);
        if( (d+m)%2 == 0 || (m == 9 && d == 30) || (m == 11 && d == 30) )
            printf("YES\n");
        else printf("NO\n");
    }
    return 0;
}
View Code

 

 

以前也写过一个直接PN分析的代码,也可以搞出来。

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<iostream>
using namespace std;

int f[2100][13][33];
int days[]={0,31,28,31,30,31,30,31,31,30,31,30,31};
bool isleap(int y)
{
    if(y%400==0||(y%100!=0&&y%4==0))return true;
    return false;
}

bool ok(int y,int m,int d)//看是不是合法的日期
{
    if(isleap(y)&&m==2)
    {
        if(d<=29)return true;
        else return false;
    }
    if(d<=days[m])return true;
    else return false;
}

int solve(int y,int m,int d)
{
    if(f[y][m][d]!=-1)return f[y][m][d];
    if(y==2001&&m==11&&d==4)return f[y][m][d]=0;

    if(y>2001)return f[y][m][d]=1;
    else if(y==2001&&m>11)  return f[y][m][d]=1;
    else if(y==2001&&m==11&&d>4)return f[y][m][d]=1;


    int ty,tm,td;
    ty=y;
    tm=m;
    td=d;

    if(isleap(y)&&m==2)
    {
        td++;
        if(td==30)
        {
            tm=3;
            td=1;
        }
    }
    else
    {
        td++;
        if(td>days[tm])
        {
            td=1;
            tm++;
            if(tm>12)ty++,tm=1;
        }
    }
    if(solve(ty,tm,td)==0)return f[y][m][d]=1;

    ty=y;
    tm=m;
    td=d;
    tm++;
    if(tm>12)ty++,tm=1;
    if(ok(ty,tm,td)&&solve(ty,tm,td)==0) return f[y][m][d]=1;

    return f[y][m][d]=0;

}

int main()
{
    memset(f,-1,sizeof(f));
    int y,m,d;
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d%d",&y,&m,&d);
        if(solve(y,m,d))printf("YES\n");
        else printf("NO\n");
    }
    return 0;
}
View Code

 

 

 

 

 

 

 

 

 

 

posted on 2013-07-22 07:46  kuangbin  阅读(2037)  评论(0编辑  收藏  举报

导航

JAVASCRIPT: