POJ 1651 Multiplication Puzzle(区间DP)

题目链接:http://poj.org/problem?id=1651

Multiplication Puzzle
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 5000   Accepted: 2988

Description

The multiplication puzzle is played with a row of cards, each containing a single positive integer. During the move player takes one card out of the row and scores the number of points equal to the product of the number on the card taken and the numbers on the cards on the left and on the right of it. It is not allowed to take out the first and the last card in the row. After the final move, only two cards are left in the row. 

The goal is to take cards in such order as to minimize the total number of scored points. 

For example, if cards in the row contain numbers 10 1 50 20 5, player might take a card with 1, then 20 and 50, scoring 
10*1*50 + 50*20*5 + 10*50*5 = 500+5000+2500 = 8000

If he would take the cards in the opposite order, i.e. 50, then 20, then 1, the score would be 
1*50*20 + 1*20*5 + 10*1*5 = 1000+100+50 = 1150.

Input

The first line of the input contains the number of cards N (3 <= N <= 100). The second line contains N integers in the range from 1 to 100, separated by spaces.

Output

Output must contain a single integer - the minimal score.

Sample Input

6
10 1 50 50 20 5

Sample Output

3650

Source

Northeastern Europe 2001, Far-Eastern Subregion
 
 
 
 

 

区间DP

dp[0][n-1]表示答案。

求解dp[i][j]的时候,就是枚举[i+1,j-1]中最后删除的元素。

dp[i][j]=min(a[k]*a[i]*a[j]+dp[i][k]+dp[k][j])   i<k<j

 

代码:

//============================================================================
// Name        : POJ.cpp
// Author      : 
// Version     :
// Copyright   : Your copyright notice
// Description : Hello World in C++, Ansi-style
//============================================================================

#include <iostream>
#include <stdio.h>
#include <algorithm>
#include <string.h>
using namespace std;
const int MAXN=110;
const int INF=0x3f3f3f3f;
int a[MAXN];
int dp[MAXN][MAXN];
int solve(int i,int j)
{
    if(dp[i][j]!=INF)return dp[i][j];
    if(j==i+1)return dp[i][j]=0;
    for(int k=i+1;k<j;k++)
        dp[i][j]=min(dp[i][j],a[k]*a[i]*a[j]+solve(i,k)+solve(k,j));
    return dp[i][j];
}
int main()
{
    //freopen("in.txt","r",stdin);
    //freopen("out.txt","w",stdout);
    int n;
    while(scanf("%d",&n)==1)
    {
        for(int i=0;i<n;i++)
            scanf("%d",&a[i]);
        for(int i=0;i<n;i++)
            for(int j=0;j<n;j++)
                dp[i][j]=INF;
        printf("%d\n",solve(0,n-1));
    }
    return 0;
}

 

 

 

 

 

posted on 2013-04-30 00:42  kuangbin  阅读(1733)  评论(0编辑  收藏  举报

导航

JAVASCRIPT: