ZOJ 3604 Help Me Escape(期望DP)

Help Me Escape

Time Limit: 2 Seconds      Memory Limit: 32768 KB

Background

 

    If thou doest well, shalt thou not be accepted? and if thou doest not well, sin lieth at the door. And unto thee shall be his desire, and thou shalt rule over him.
    And Cain talked with Abel his brother: and it came to pass, when they were in the field, that Cain rose up against Abel his brother, and slew him.
    And the LORD said unto Cain, Where is Abel thy brother? And he said, I know not: Am I my brother's keeper?
    And he said, What hast thou done? the voice of thy brother's blood crieth unto me from the ground.
    And now art thou cursed from the earth, which hath opened her mouth to receive thy brother's blood from thy hand;
    When thou tillest the ground, it shall not henceforth yield unto thee her strength; a fugitive and a vagabond shalt thou be in the earth.

 

—— Bible Chapter 4

 

 

Now Cain is unexpectedly trapped in a cave with N paths. Due to LORD's punishment, all the paths are zigzag and dangerous. The difficulty of the ith path is ci.

Then we define f as the fighting capacity of Cain. Every day, Cain will be sent to one of the N paths randomly.

Suppose Cain is in front of the ith path. He can successfully take ti days to escape from the cave as long as his fighting capacity f is larger than ci. Otherwise, he has to keep trying day after day. However, if Cain failed to escape, his fighting capacity would increase ci as the result of actual combat. (A kindly reminder: Cain will never died.)

As for ti, we can easily draw a conclusion that ti is closely related to ci. Let's use the following function to describe their relationship:

 

After D days, Cain finally escapes from the cave. Please output the expectation of D.

Input

The input consists of several cases. In each case, two positive integers N and f (n ≤ 100, f ≤ 10000) are given in the first line. The second line includes N positive integers ci (ci ≤ 10000, 1 ≤ i ≤ N)

Output

For each case, you should output the expectation(3 digits after the decimal point).

Sample Input

3 1
1 2 3

Sample Output

6.889


Author: WU, Yingxin
Contest: ZOJ Monthly, August 2012

 

 

期望DP。

题意:
一只吸血鬼,有n条路给他走,每次他随机走一条路,
每条路有个限制,如果当时这个吸血鬼的攻击力大于
等于某个值,那么就会花费t天逃出去,否则,花费1天
的时间,并且攻击力增加,问他逃出去的期望

用记忆化搜索做,很好理解。

/*
题意:
一只吸血鬼,有n条路给他走,每次他随机走一条路,
每条路有个限制,如果当时这个吸血鬼的攻击力大于
等于某个值,那么就会花费t天逃出去,否则,花费1天
的时间,并且攻击力增加,问他逃出去的期望

记忆化搜索做
*/

#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<string.h>
#include<math.h>
using namespace std;
const int MAXN=200010;

double dp[MAXN];

int c[110];
int n;

double solve(int f)
{
    if(dp[f]>0)return dp[f];

    dp[f]=0;
    for(int i=0;i<n;i++)
    {
        if(f>c[i])
        {
            double temp=(1.0+sqrt(5))/2*c[i]*c[i];
            int t=(int)temp;
            dp[f]+=(double)t/n;
        }
        else
        {
            dp[f]+=(1+solve(f+c[i]))/n;
        }
    }
    return dp[f];
}
int main()
{
    int f;
    while(scanf("%d%d",&n,&f)!=EOF)
    {
        for(int i=0;i<n;i++)scanf("%d",&c[i]);
        memset(dp,0,sizeof(dp));
        printf("%.3lf\n",solve(f));
    }
    return 0;
}

 

posted on 2012-10-06 15:49  kuangbin  阅读(1619)  评论(0编辑  收藏  举报

导航

JAVASCRIPT: