codevs 1462 素数和

1462 素数和

 
题目描述 Description

给定2个整数a,b 求出它们之间(不含a,b)所有质数的和。

输入描述 Input Description

一行,a b(0<=a,b<=65536)

输出描述 Output Description

一行,a,b之间(不含a,b)所有素数的和。

样例输入 Sample Input

39 1224

样例输出 Sample Output

111390

#include<iostream>
#include<cstdio>
#include<cmath>
using namespace std;
int main()
{
    int flag=0,a,b,tot=0;
    scanf("%d%d",&a,&b);
    if(a>b)swap(a,b);
    for(int i=a+1;i<b;++i)
    {
        flag=1;
        for(int j=2;j<=sqrt(i);++j)
        {
            if(i%j==0)
            {
                flag=0;
                break;
            }
        }
        if(flag==1)
            tot+=i;
    }
    printf("%d",tot);
    return 0;
}

swap即交换括号内逗号分隔的两参数

posted @ 2017-04-14 21:21  快乐永恒  阅读(133)  评论(0编辑  收藏  举报