rsync 参数说明及使用参数笔记好文摘抄

一.前言

最近发现rsync挺好用的……不过参数有点多,所以这儿写一篇给自己以后要用的时候做个参考。

二.参数说明

这儿全是我翻资料连蒙带猜(有些实在是不好解释)翻译出来的,请各位转载的留个名啊,虽然不是多高端的,但是也贼烦

①.daemon(服务端)模式:

②.普通(客户端)模式:

 

三.服务端配置

服务端配置文件默认位置/etc/rsyncd.conf

分为两块,最开头的是全局参数,部分可以由daemon进程运行参数覆盖,如下

参数说明默认值
address 在独立运行时,用于指定的服务器运行的 IP 地址。由 xinetd 运行时将忽略此参数,使用命令行上的 –address 选项替代。 本地所有IP
port 指定 rsync 守护进程监听的端口号。 由 xinetd 运行时将忽略此参数,使用命令行上的–port 选项替代。 873
motd file 指定一个消息文件,当客户连接服务器时该文件的内容显示给客户。 无
pid file rsync 的守护进程将其 PID 写入指定的文件。 无
log file 指定 rsync 守护进程的日志文件,而不将日志发送给 syslog。 无
syslog facility 指定 rsync 发送日志消息给 syslog 时的消息级别。 daemon
socket options 指定自定义 TCP 选项。 无

另外的就是模块参数了

1.基础参数

参数说明默认值
path 指定当前模块在 rsync 服务器上的同步路径,该参数是必须指定的。 无
comment 给模块指定一个描述,该描述连同模块名在客户连接得到模块列表时显示给客户。 无

2.控制参数

参数说明默认值
use chroot 若为 true,则 rsync 在传输文件之前首先 chroot 到 path 参数所指定的目录下。这样做的原因是实现额外的安全防护,但是缺点是需要 root 权限,并且不能备份指向 path 外部的符号连接所指向的目录文件。 true
uid 指定该模块以指定的 UID 传输文件。 nobody
gid 指定该模块以指定的 GID 传输文件。 nobody
max connections 指定该模块的最大并发连接数量以保护服务器,超过限制的连接请求将被告知随后再试。 0(没有限制)
lock file 指定支持 max connections 参数的锁文件。 /var/run/rsyncd.lock
list 指定当客户请求列出可以使用的模块列表时,该模块是否应该被列出。如果设置该选项为 false,可以创建隐藏的模块。 true
read only 指定是否允许客户上传文件。若为 true 则不允许上传;若为 false 并且服务器目录也具有读写权限则允许上传。 true
write only 指定是否允许客户下载文件。若为 true 则不允许下载;若为 false 并且服务器目录也具有读权限则允许下载。 false
ignore errors 指定 在 rsync 服务器上运行 delete 操作时是否忽略 I/O 错误。一般来说 rsync 在出现 I/O 错误时将将跳过 –delete 操作,以防止因为暂时的资源不足或其它 I/O 错误导致的严重问题。 true
ignore nonreadable 指定 rysnc 服务器完全忽略那些用户没有访问权限的文件。这对于在需要备份的目录中有些不应该被备份者获得的文件时是有意义的。 false
timeout 该选项可以覆盖客户指定的 IP 超时时间。从而确保 rsync 服务器不会永远等待一个崩溃的客户端。对于匿名 rsync 服务器来说,理想的数字是 600(单位为秒)。 0 (未限制)
dont compress 用来指定那些在传输之前不进行压缩处理的文件。该选项可以定义一些不允许客户对该模块使用的命令选项列表。必须使用选项全名,而不能是简称。当发生拒绝某个选项的情况时,服务器将报告错误信息然后退出。例如,要防止使用压缩,应该是:”dont compress = *”。 *.gz *.tgz *.zip *.z *.rpm *.deb *.iso *.bz2 *.tbz

3.文件过滤参数

参数说明默认值
exclude 指定多个由空格隔开的多个文件或目录(相对路径),并将其添加到 exclude 列表中。这等同于在客户端命令中使用 –exclude 来指定模式。 空
exclude from 指定一个包含 exclude 规则定义的文件名,服务器从该文件中读取 exclude 列表定义。 空
include 指定多个由空格隔开的多个文件或目录(相对路径),并将其添加到 include 列表中。这等同于在客户端命令中使用 –include 来指定模式 。 空
include from 指定一个包含 include 规则定义的文件名,服务器从该文件中读取 include 列表定义。 空
  • 一个模块只能指定一个 exclude 参数、一个 include 参数。
  • 结合 include 和 exclude 可以定义复杂的 exclude/include 规则 。
  • 这几个参数分别与相应的 rsync 客户命令选项等价,唯一不同的是它们作用在服务器端。

4.用户认证参数

参数说明默认值
auth users 指定由空格或逗号分隔的用户名列表,只有这些用户才允许连接该模块。这里的用户和系统用户没有任何关系。用户名和口令以明文方式存放在 secrets file 参数指定的文件中。 (匿名方式)
secrets file 指定一个 rsync 认证口令文件。只有在 auth users 被定义时,该文件才起作用。 空
strict modes 指定是否监测口令文件的权限。若为 true 则口令文件只能被 rsync 服务器运行身份的用户访问,其他任何用户不可以访问该文件。 true
  • rsync 认证口令文件的权限一定是 600,否则客户端将不能连接服务器。
  • rsync 认证口令文件中每一行指定一个"用户名:口令"对,格式为:

 

5.访问控制参数

参数说明默认值
hosts allow 用一个主机列表指定哪些主机客户允许连接该模块。不匹配主机列表的主机将被拒绝。 *
hosts deny 用一个主机列表指定哪些主机客户不允许连接该模块。 空

客户主机列表定义可以是以下形式:

  • 单个IP地址。例如:192.168.0.1
  • 整个网段。例如:192.168.0.0/24,192.168.0.0/255.255.255.0
  • 可解析的单个主机名。例如:centos,centos.smartraining.cn
  • 域内的所有主机。例如:*.smartraining.cn
  • “*”则表示所有。
  • 多个列表项要用空格间隔。

6.日志参数

参数说明默认值
transfer logging 使 rsync 服务器将传输操作记录到传输日志文件。 false
log format 指定传输日志文件的字段。 ”%o %h [%a] %m (%u) %f %l”

设置了”log file”参数时,在日志每行的开始会添加”%t [%p]“。

  • 可以使用的日志格式定义符如下所示:
    • %a - 远程IP地址
    • %h - 远程主机名
    • %l - 文件长度字符数
    • %p - 该次 rsync 会话的 PID
    • %o - 操作类型:”send” 或 “recv”
    • %f - 文件名
    • %P - 模块路径
    • %m - 模块名
    • %t - 当前时间
    • %u - 认证的用户名(匿名时是 null)
    • %b - 实际传输的字节数
    • %c - 当发送文件时,记录该文件的校验码

这部分是网上看得,实在懒得翻译man了,具体来源完全不知道,我看到那位仁兄也是转载来的……

这儿拿我前一篇文章写的举个栗子方便解释

 

四.客户端命令

如果配置了密码,请务必先丢个密码文件,然后保证它的权限为600

 

 

这样能列出服务端可同步的文件(如果搞单向同步你肯定就用不着这个了

然后手动同步我们可以这样(当然手动是可以不指定password-file的,反正会提示你输密码,如果写到脚本或者crontab里就必须带上了)

敲黑板,P参数是给你看着玩的,不然鬼知道同步到啥程度了,写脚本里就别带了,单向传输脚本里如果要那个断点续传请自己做好命令返回状态的判断,因为单向传输是一次性的,如果是同步就没必要了,毕竟你会隔阵子就运行

z是压缩,如果你cpu不行或者需要降低资源消耗,可以带上--compress-level来减小下压缩率,0-9哦,从低到高资源消耗越来越大,当然你也可以不压缩,文本内容我觉得开个1或者2就很给力了

五.常见错误

问题一:

问题二:

问题三:

问题四:

问题五:

问题六:

问题七:

问题八:

 

六.配合inotify使用

inotify我之前在搭建dns来同步配置的时候就用过——>传送门

简单的一个脚本,可以监控/data/目录,递归模式,任何修改,删除,创建,修改属性的事件都会触发同步并记录到日志中,对于要自动化处理某些东西挺好用的

posted @ 2018-06-10 12:25  口水哥  阅读(18352)  评论(1)    收藏  举报