求余

Big Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7179    Accepted Submission(s): 4959


Problem Description
As we know, Big Number is always troublesome. But it's really important in our ACM. And today, your task is to write a program to calculate A mod B.

To make the problem easier, I promise that B will be smaller than 100000.

Is it too hard? No, I work it out in 10 minutes, and my program contains less than 25 lines.
 

Input
The input contains several test cases. Each test case consists of two positive integers A and B. The length of A will not exceed 1000, and B will be smaller than 100000. Process to the end of file.
 

Output
For each test case, you have to ouput the result of A mod B.
 

Sample Input
2 3 12 7 152455856554521 3250
 

Sample Output
2 5 1521
 

Author
Ignatius.L

#include<cstdio>
#include<cstring>
char a[10001];
int main()
{
	int  b,n,m;
	while(scanf("%s",&a)!=EOF)
	{
	     scanf("%d",&b);	
	     int n=strlen(a);
	     int yu=0;
	     for(int i=0;i<n;i++ )
	      {	
		    yu=yu*10;
	         yu=yu+a[i]-'0';
			 yu=yu%b;	
        } 
	   
	   printf("%d\n",yu);	
		}
	return 0;
}

posted @ 2019-12-12 09:01  千金一发  阅读(130)  评论(0编辑  收藏  举报