Rikka with Graph

Problem Description
As we know, Rikka is poor at math. Yuta is worrying about this situation, so he gives Rikka some math tasks to practice. There is one of them:

Yuta has a non-direct graph with n vertices and n+1 edges. Rikka can choose some of the edges (at least one) and delete them from the graph.

Yuta wants to know the number of the ways to choose the edges in order to make the remaining graph connected.

It is too difficult for Rikka. Can you help her?
 

Input
The first line contains a number T(T30)——The number of the testcases.

For each testcase, the first line contains a number n(n100).

Then n+1 lines follow. Each line contains two numbers u,v , which means there is an edge between u and v.
 

Output
For each testcase, print a single number.
 

Sample Input
1 3 1 2 2 3 3 1 1 3
 

Sample Output
9

n个点给出n+1条边 去掉几条边后还能连接在一起 问共有几种情况

n个点连在一起最少要n+1条边 只有去掉一条边 和两条边的情况 直接枚举每一种一种情况 再看剩下的边还能否连接在一起即可

#include<stdio.h>
#include<cstring>
int pre[1001];
int du[1001];
int n;
struct node
{
	int s,w;
}xian[1001];
void dabiao()
{
	for(int i=1;i<=n;i++)
	{
		pre[i]=i;
	}
}
int find(int p)  //路径压缩 
{  
    int r=p;  
    int t;  
    while(p!=pre[p])  
    p=pre[p];  
    while(r!=p)  
    {  
        t=pre[r];  
        pre[r]=p;  
        r=t;  
    }  
    return p;  
} 
void merge(int x,int y)
{
	int fx=find(x);
	int fy=find(y);
	if(fx!=fy)
	{
		pre[fx]=fy;
	}
}
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		int zongsum=0;
		scanf("%d",&n);
	     for(int i=1;i<=n+1;i++)
		 {
		 	scanf("%d%d",&xian[i].s ,&xian[i].w );
		  } 
		  for(int i=1;i<=n+1;i++) //去掉一条边
		  {
		  	dabiao();//注意初始化 
		  	 for(int j=1;j<=n+1;j++) 
		  	 {
		  		if(i==j) //将第i条边取出 
		  		continue;
		  		merge(xian[j].s ,xian[j].w ); 
	      	 }
			   int sum=0;
			   for(int i=1;i<=n;i++)
			   {
			  	if(pre[i]==i)
			  	  sum++;
			   } 
			   if(sum==1)
			   {
			   	zongsum++;
			   }
		  }
		  for(int i=1;i<=n+1;i++)//取出两条边 
		  {
		  	  for(int j=i+1;j<=n+1;j++)
		   	{
		   		dabiao();  //注意初始化 
		  		for(int k=1;k<=n+1;k++)
		  		{
		  			if(k==i||k==j)//取出第i j 条边 
		  			continue;
		  			merge(xian[k].s ,xian[k].w );
				  }
				   int sum=0;
			   for(int i=1;i<=n;i++)
			   {
			  	if(pre[i]==i)
			  	sum++;
			   } 
			   if(sum==1)
			   {
			   	zongsum++;
			   }
			}
		   } 
		   printf("%d\n",zongsum);
	}
		return 0;
}


posted @ 2019-12-12 09:00  千金一发  阅读(86)  评论(0编辑  收藏  举报