PCL库与Qt4库兼容性修改

在使用 PCL-All-in-One 预编译库时,如果Qt4库 没有安装在默认位置,在编译时,会报错,无法找到QtXXX库等问题

解决办法:

1, PCL-All-in-One 和Qt4 都安装在默认位置,并且版本配合 (比如 pcl1.6 和Qt4.8.0)。

2,如果使用cmake+nmake系列,可以在生成sln之后,在修改sln工程中Qt库的位置。可以利用grepWin之类的工具辅助修改。

3,修改VTK相关文件(如果用QtCreator+mingw)

   VTKConfigQt.cmake
   VTKTargets-debug.cmake
   VTKTargets-release.cmake

  将其中的Qt路径 修改成实际路径,即可。

 

4,自行链接PCL相关的库。

(可选)将PCL_ROOT等路径加入到path中;

 在项目中加入PCL和3rdparty的include,和lib路径

 在项目中加入需要的库 opengl32.lib pcl_xxx.lib flann_xxx.lib libboost_xxx.lib vtkXXX.lib QtXXX.lib等等,注意区分debug和release

 

参考如下

http://m.blog.csdn.net/blog/renshengrumenglibing/9073675

http://www.pcl-users.org/Error-compiling-Trunk-in-Win-7-x64-an-VS-2010-td4026570.html

http://www.pcl-users.org/Default-QT-Library-path-for-prebuilt-PCL-td4023315.html

posted @ 2013-10-31 16:24  kevinzhwl  阅读(...)  评论(... 编辑 收藏