[poj2234] Matches Game

Description

Here is a simple game. In this game, there are several piles of matches and two players. The two player play in turn. In each turn, one can choose a pile and take away arbitrary number of matches from the pile (Of course the number of matches, which is taken away, cannot be zero and cannot be larger than the number of matches in the chosen pile). If after a player’s turn, there is no match left, the player is the winner. Suppose that the two players are all very clear. Your job is to tell whether the player who plays first can win the game or not.

Input

The input consists of several lines, and in each line there is a test case. At the beginning of a line, there is an integer M (1 <= M <=20), which is the number of piles. Then comes M positive integers, which are not larger than 10000000. These M integers represent the number of matches in each pile.

Output

For each test case, output "Yes" in a single line, if the player who play first will win, otherwise output "No".

Sample Input

2 45 45
3 3 6 9

Sample Output

No
Yes
Solution

Nim游戏,直接异或
#include <stdio.h>
int n, ans, x;
int main()
	{
	while(~scanf("%d", &n))
		{
		ans = 0;
		for(register int i = 0; i < n; i++) scanf("%d", &x), ans ^= x;
		if(ans) putchar('Y'), putchar('e'), putchar('s'), putchar('\n');
		else putchar('N'), putchar('o'), putchar('\n');
		}
	return 0;
	}

 

posted @ 2017-04-16 09:39  keshuqi  阅读(228)  评论(0编辑  收藏  举报