风言枫语  
Stock Chase
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 455   Accepted: 131

Description

I have to admit, the solution I proposed last year for solving the bank cash crisis didn’t solve the whole economic crisis. As it turns out, companies don’t have that much cash in the first place. They have assets which are primarily shares in other companies. It is common, and acceptable, for one company to own shares in another. What complicates the issue is for two companies to own shares in each other at the same time. If you think of it for a moment, this means that each company now (indirectly) controls its own shares.
New market regulation is being implemented: No company can control shares in itself, whether directly or indirectly. The Stock Market Authority is looking for a computerized solution that will help it detect any buying activity that will result in a company controlling its own shares. It is obvious why they need a program to do so, just imagine the situation where company A buying shares in B, B buying in C, and then C buying in A. While the first two purchases are acceptable. The third purchase should be rejected since it will lead to the three companies controlling shares in themselves. The program will be given all purchasing transactions in chronological order. The program should reject any transaction that could lead to one company controlling its own shares. All other transactions are accepted.

Input

Your program will be tested on one or more test cases. Each test case is specified on T + 1 lines. The first line specifies two positive numbers: (0 < N ≤ 234) is the number of companies and (0 < T ≤ 100, 000) is the number of transactions. T lines follow, each describing a buying transaction. Each transaction is specified using two numbers A and B where (0 < A,B ≤ N) indicating that company A wants to buy shares in company B.
The last line of the input file has two zeros.

Output

For each test case, print the following line:
k. R
Where k is the test case number (starting at one,) R is the number of transactions that should be rejected.

Sample Input

3 6
1 2
1 3
3 1
2 1
1 2
2 3
0 0

Sample Output

1. 2

Source

 
题目大意:有N个公司,A公司可以买B公司的股票, B公司可以买C公司的股票,如此A公司会间接持有C公司的股票,这种操作非法,所以不能传递,按照时间顺序给出T次购买请求,问有多少次非法的购买请求会被拒绝。
 
解题思路:运用dp的思想压缩下路径。
 
 
#include <iostream>
#include <cstdio>
using namespace std;

const int maxn=300;
bool dp[maxn][maxn];
int n,m,casen=0;

void initial(){
    for(int i=0;i<=n;i++)
    for(int j=0;j<=n;j++)
    dp[i][j]=false;
    for(int i=0;i<=n;i++)
    dp[i][i]=true;
}

void computing(){
    int ans=0,u,v;
    while(m--){
        scanf("%d%d",&u,&v);
        if(dp[v][u]){
            ans++;
        }else if(!dp[u][v]){
            dp[u][v]=true;
            for(int i=1;i<=n;i++){
                if(!dp[i][u]) continue;
                dp[i][v]=true;
                for(int j=1;j<=n;j++){
                    if(!dp[v][j]) continue;
                    dp[i][j]=true;
                    dp[u][j]=true;
                }
            }
        }
    }
    casen++;
    printf("%d. %d\n",casen,ans);
}

int main(){
    while(scanf("%d%d",&n,&m)!=EOF && (m||n)){
        initial();
        computing();
    }
    return 0;
}

 
 

 

posted on 2013-09-26 22:16  风言枫语  阅读(174)  评论(0编辑  收藏  举报