记一次tomcat部署失败:Invalid byte tag in constant pool: 19

记一次tomcat部署失败:Invalid byte tag in constant pool: 19

现象

之前有一个项目测试环境部署成功,上线时tomcat启动失败。看了下 catalina.out日志。由于当时未及时记录,所以完整异常已经遗忘。部分异常如下:

org.apache.tomcat.util.bcel.classfile.ClassFormatException:
Invalid byte tag in constant pool: 19

定位

因为代码都一样,所以应该是环境问题导致的。首先检查了下测试环境和线上环境的tomcat版本,分别是8.0和7.4。开始怀疑tomcat版本的问题,想了想代码中是否做了基础代码的修改。想起来升级了log4j-api到2.10.0。开始怀疑是tomcat和log4j-api不兼容。为了确认,开始google,看到这篇博客Invalid byte tag in constant pool: 19,这时已经基本确认了。升级线上tomcat,重新部署,DONE!

使用tomcat 7.0

<!-- 日志相关坐标beg -->
        <dependency>
            <groupId>log4j</groupId>
            <artifactId>log4j</artifactId>
            <version>1.2.13</version>
        </dependency>
        <dependency>
            <groupId>org.slf4j</groupId>
            <artifactId>slf4j-log4j12</artifactId>
            <version>1.7.25</version>
        </dependency>
        <dependency>
            <groupId>org.slf4j</groupId>
            <artifactId>slf4j-api</artifactId>
            <version>1.7.25</version>
        </dependency>

posted @ 2019-05-17 16:38  愿世界对你温柔相待  Views(554)  Comments(0)    收藏  举报