2017 World Final E Need For Speed(二分)

Sheila is a student and she drives a typical student car: it is old, slow, rusty, and falling apart. Recently, the needle on the speedometer fell off. She glued it back on, but she might have placed it at the wrong angle. Thus, when the speedometer reads v, her true speed is v+c, where c is an unknown constant (possibly negative).

Sheila made a careful record of a recent journey and wants to use this to compute c. The journey consisted of n segments. In the ith segment she traveled a distance of di and the speedometer read vi for the entire segment. This whole journey took time t. Help Sheila by computing c.

Note that while Sheila’s speedometer might have negative readings, her true speed was greater than zero for each segment of the journey.

Input

The first line of input contains two integers (1≤n≤1000), the number of sections in Sheila’s journey, and t (1≤t≤106), the total time. This is followed by n lines, each describing one segment of Sheila’s journey. The ith of these lines contains two integers di (1≤di≤1000) and v (|vi|≤1000), the distance and speedometer reading for the ith segment of the journey. Time is specified in hours, distance in miles, and speed in miles per hour.

Output

Display the constant c in miles per hour. Your answer should have an absolute or relative error of less than 10−6.

Sample Input 1Sample Output 1
3 5
4 -1
4 0
10 3
3.000000000
Sample Input 2Sample Output 2
4 10
5 3
2 2
3 6
3 1
-0.508653377

题意:

该旅程分为n个部分,每个部分的距离为d[i],速度表所读取的速度为v[i] (v>0),但真实速度为v[i]+c。已知旅程总时间为t,在总误差不超过1e-6的条件下,求c。

思路:

对于方程SUM(d[i]/s[i]+c),利用二分求解的方法求c。

#include<bits/stdc++.h> 
#define MAX 1050
using namespace std;
int d[MAX],v[MAX],n;
double t;
int ok(double c)
{
    double T=0;
    for(int i=0;i<n;i++)
    {
        if(c+v[i]<=0)return 0; //c偏小 
        else T+=1.0*d[i]/(v[i]*1.0+c); 
    }
    if(T>t)return 0; 
    else return 1;             //c偏大 
}
int main()
{
    int i;
    while(scanf("%d%lf",&n,&t)!=EOF)
    {
        for(i=0;i<n;i++)
            scanf("%d%d",&d[i],&v[i]);
        double low=-1e9,high=1e9;
        while(high-low>1e-6)
        {
            double mid=(high+low)*0.5;
            if(ok(mid))
                high=mid;
            else low=mid;
        }
        printf("%.9f\n",(high+low)*0.5);
    }
    return 0;
}

 

posted @ 2018-09-08 11:38  真想不出名字了  阅读(309)  评论(0编辑  收藏  举报