hadoop安装配置问题,

nodename 没启动,看logs 里的NameNode.log 

发现,data/dfs/name/

里的current 权限是root 要改下——

chown hadoop:hadoop current

 

 

启动报错——看写入的log文件,

starting resourcemanager, logging to /usr/java/hadoop-2.6.2/logs/yarn-hadoop-resourcemanager-hadoop.com.out
log4j:ERROR setFile(null,true) call failed.
java.io.FileNotFoundException: /usr/java/hadoop-2.6.2/logs/yarn-hadoop-resourcemanager-hadoop.com.log (Permission denied)
at java.io.FileOutputStream.open0(Native Method)
at java.io.FileOutputStream.open(FileOutputStream.java:270)
at java.io.FileOutputStream.<init>(FileOutputStream.java:213)

mapereduce_shuffle
java.lang.RuntimeException: No class defined for mapereduce_shuffle

发现在的异常——mapereduce_shuffle 写错了

apereduce_shuffle
java.lang.RuntimeException: No class defined for mapereduce_shuffle
at org.apache.hadoop.yarn.server.nodemanager.containermanager.AuxServices.serviceInit(AuxServices.java:125)
at org.apache.hadoop.service.AbstractService.init(AbstractService.java:163)
at org.apache.hadoop.service.CompositeService.serviceInit(CompositeService.java:107)
at org.apache.hadoop.yarn.server.nodemanager.containermanager.ContainerManagerImpl.serviceInit(ContainerManagerImpl.java:237)
at org.apache.hadoop.service.AbstractService.init(AbstractService.java:163)
at org.apache.hadoop.service.CompositeService.serviceInit(CompositeService.java:107)
at org.apache.hadoop.yarn.server.nodemanager.NodeManager.serviceInit(NodeManager.java:255)
at org.apache.hadoop.service.AbstractService.init(AbstractService.java:163)
at org.apache.hadoop.yarn.server.nodemanager.NodeManager.initAndStartNodeManager(NodeManager.java:480)

posted @ 2016-02-25 16:49  R142857  阅读(115)  评论(0)    收藏  举报