POJ 1006 Biorhythms

链接:http://poj.org/problem?id=1006

Biorhythms

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 121231 Accepted: 38168

Description

Some people believe that there are three cycles in a person's life that start the day he or she is born. These three cycles are the physical, emotional, and intellectual cycles, and they have periods of lengths 23, 28, and 33 days, respectively. There is one peak in each period of a cycle. At the peak of a cycle, a person performs at his or her best in the corresponding field (physical, emotional or mental). For example, if it is the mental curve, thought processes will be sharper and concentration will be easier.
Since the three cycles have different periods, the peaks of the three cycles generally occur at different times. We would like to determine when a triple peak occurs (the peaks of all three cycles occur in the same day) for any person. For each cycle, you will be given the number of days from the beginning of the current year at which one of its peaks (not necessarily the first) occurs. You will also be given a date expressed as the number of days from the beginning of the current year. You task is to determine the number of days from the given date to the next triple peak. The given date is not counted. For example, if the given date is 10 and the next triple peak occurs on day 12, the answer is 2, not 3. If a triple peak occurs on the given date, you should give the number of days to the next occurrence of a triple peak.

Input

You will be given a number of cases. The input for each case consists of one line of four integers p, e, i, and d. The values p, e, and i are the number of days from the beginning of the current year at which the physical, emotional, and intellectual cycles peak, respectively. The value d is the given date and may be smaller than any of p, e, or i. All values are non-negative and at most 365, and you may assume that a triple peak will occur within 21252 days of the given date. The end of input is indicated by a line in which p = e = i = d = -1.

Output

For each test case, print the case number followed by a message indicating the number of days to the next triple peak, in the form:

Case 1: the next triple peak occurs in 1234 days.

Use the plural form ``days'' even if the answer is 1.


Sample Input

0 0 0 0
0 0 0 100
5 20 34 325
4 5 6 7
283 102 23 320
203 301 203 40
-1 -1 -1 -1

Sample Output

Case 1: the next triple peak occurs in 21252 days.
Case 2: the next triple peak occurs in 21152 days.
Case 3: the next triple peak occurs in 19575 days.
Case 4: the next triple peak occurs in 16994 days.
Case 5: the next triple peak occurs in 8910 days.
Case 6: the next triple peak occurs in 10789 days.

Source
East Central North America 1999

大意——人生来就有三个生理周期,分别为体力、感情和智力周期,它们的周期长度为23天、28天和33天。对于每一个人,我们想知道何时三个高峰落在同一天。对于每一个周期,我们会给出从当前年份的第一天開始,到出现高峰的天数(不一定是第一次高峰出现的时间)。问:给定一个从当年第一天開始数的天数,输出从给定时间開始(不包含给定时间)下一次三个高峰落在同一天的时间(距给定时间的天数)。

思路——由于全部给定时间是非负的而且小于365, 所求的时间小于21252。

所以仅仅需把天数从1開始枚举直至满足条件就可以。

复杂度分析——时间复杂度:O(n),空间复杂度:O(1)

附上AC代码:


#include <iostream>
#include <cstdio>
#include <iomanip>
#include <string>
#include <cstring>
#include <cmath>
#include <algorithm>
using namespace std;
const double PI = acos(-1.0);
const int loop1 = 23;
const int loop2 = 28;
const int loop3 = 33;

int main()
{
    ios::sync_with_stdio(false);
    int p, e, i, d;
    int cas = 1;
    while (cin >> p >> e >> i >> d)
    {
        if (p==-1 && e==-1 && i==-1 && d==-1)
            break;
        int day = 1;
        while (day)
        {
            if ((day-p)%loop1==0 && (day-e)%loop2==0 && (day-i)%loop3==0 && day>d)
                break;
            day++;
        }
        day -= d;
        cout << "Case " << cas << ": the next triple peak occurs in " << day << " days.\n";
        cas++;
    }
    return 0;
}


posted @ 2017-08-19 17:00  jzdwajue  阅读(127)  评论(0编辑  收藏  举报