Rank List

Rank List
Time Limit: 10000MS Memory Limit: 65536K
Total Submissions: 9837 Accepted: 3303

Description
Li Ming is a good student. He always asks the teacher about his rank in his class after every exam, which makes the teacher very tired. So the teacher gives him the scores of all the student in his class and asked him to get his rank by himself. However, he has so many classmates, and he can’t know his rank easily. So he tends to you for help, can you help him?

Input
The first line of the input contains an integer N (1 <= N <= 10000), which represents the number of student in Li Ming’s class. Then come N lines. Each line contains a name, which has no more than 30 letters. These names represent all the students in Li Ming’s class and you can assume that the names are different from each other.

In (N+2)-th line, you’ll get an integer M (1 <= M <= 50), which represents the number of exams. The following M parts each represent an exam. Each exam has N lines. In each line, there is a positive integer S, which is no more then 100, and a name P, which must occur in the name list described above. It means that in this exam student P gains S scores. It’s confirmed that all the names in the name list will appear in an exam.

Output
The output contains M lines. In the i-th line, you should give the rank of Li Ming after the i-th exam. The rank is decided by the total scores. If Li Ming has the same score with others, he will always in front of others in the rank list.

Sample Input

3
Li Ming
A
B
2
49 Li Ming
49 A
48 B
80 A
85 B
83 Li Ming

Sample Output

1
2

Source
POJ Monthly,Li Haoyuan
map的简单应用

#include <iostream>
#include <cmath>
#include <map>
#include <cstring>
#include <cstdlib>
#include <stdio.h>
#include <string>
#include <queue>
#include <algorithm>

using namespace std;

const int INF = 0x3f3f3f3f;

const int MAX = 55000;

map<string ,int>M;

int n,m;
int main()
{
    scanf("%d",&n);
    int data;
    char s[1000];
    getchar();
    for(int i=0;i<n;i++)
    {
        gets(s);
        M[s]=0;
    }
    scanf("%d",&m);
    map<string ,int>::iterator it;
    getchar();
    for(int i=0;i<m;i++)
    {
        for(int i=0;i<n;i++)
        {
            scanf("%d",&data);
            getchar();
            gets(s);
            M[s]+=data;
        }
        int ans=1;
        for(it=M.begin();it!=M.end();it++)
        {
            if(it->second>M["Li Ming"])
            {
                ans++;
            }
        }
        printf("%d\n",ans);
    }
    return 0;
}
posted @ 2015-08-14 09:41  一骑绝尘去  阅读(323)  评论(0编辑  收藏  举报