Ahui Writes Word

Ahui Writes Word
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2356 Accepted Submission(s): 863

Problem Description
We all know that English is very important, so Ahui strive for this in order to learn more English words. To know that word has its value and complexity of writing (the length of each word does not exceed 10 by only lowercase letters), Ahui wrote the complexity of the total is less than or equal to C.
Question: the maximum value Ahui can get.
Note: input words will not be the same.

Input
The first line of each test case are two integer N , C, representing the number of Ahui’s words and the total complexity of written words. (1 ≤ N ≤ 100000, 1 ≤ C ≤ 10000)
Each of the next N line are a string and two integer, representing the word, the value(Vi ) and the complexity(Ci ). (0 ≤ Vi , Ci ≤ 10)

Output
Output the maximum value in a single line for each test case.

Sample Input

5 20
go 5 8
think 3 7
big 7 4
read 2 6
write 3 5

Sample Output

15
Hint

Input data is huge,please use “scanf(“%s”,s)”
题意:每个单词都有自己的价值和复杂度,给你总的复杂度,计算最大的价值
01背包问题,但是n为100000,c为10000,所以01背包的做法必定超时,所以要转化,因为0 ≤ Vi , Ci ≤ 10,所以单词中价值与复杂度必定有大量的重复,重复的可以看成同一个,统计个数,转化为多重背包问题,二进制优化求解

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <queue>
#include <algorithm>
#define LL long long
using namespace std;

const int INF = 0x3f3f3f3f;

const int MAX = 11000;

int  a[15][15];

char str[15];

int n,c;

int Dp[MAX];

int main()
{
    int v,ci;
    while(~scanf("%d %d",&n,&c))
    {
        memset(a,0,sizeof(a));
        for(int i=0; i<n; i++)
        {
            scanf("%s %d %d",str,&v,&ci);
            a[v][ci]++;
        }
        memset(Dp,0,sizeof(Dp));
        for(int i=0; i<=10; i++)
        {
            for(int j=0; j<=10; j++)
            {
                if(a[i][j])
                {
                    int bite=1;
                    int num=a[i][j];
                    while(num)
                    {
                        num-=bite;
                        for(int k=c; k>=bite*j; k--)
                        {
                            Dp[k]=max(Dp[k],Dp[k-bite*j]+bite*i);
                        }
                        if(bite*2<=num)
                        {
                            bite*=2;
                        }
                        else
                        {
                            bite=num;
                        }
                    }
                }
            }
        }
        printf("%d\n",Dp[c]);
    }
    return 0;
}
posted @ 2015-08-17 14:29  一骑绝尘去  阅读(174)  评论(0编辑  收藏  举报