POJ River Hopscotch 二分搜索

Every year the cows hold an event featuring a peculiar version of hopscotch that involves carefully jumping from rock to rock in a river. The excitement takes place on a long, straight river with a rock at the start and another rock at the end, L units away from the start (1 ≤ L ≤ 1,000,000,000). Along the river between the starting and ending rocks, N (0 ≤ N ≤ 50,000) more rocks appear, each at an integral distance Di from the start (0 < Di < L).

To play the game, each cow in turn starts at the starting rock and tries to reach the finish at the ending rock, jumping only from rock to rock. Of course, less agile cows never make it to the final rock, ending up instead in the river.

Farmer John is proud of his cows and watches this event each year. But as time goes by, he tires of watching the timid cows of the other farmers limp across the short distances between rocks placed too closely together. He plans to remove several rocks in order to increase the shortest distance a cow will have to jump to reach the end. He knows he cannot remove the starting and ending rocks, but he calculates that he has enough resources to remove up to rocks (0 ≤ M ≤ N).

FJ wants to know exactly how much he can increase the shortest distance *before*he starts removing the rocks. Help Farmer John determine the greatest possible shortest distance a cow has to jump after removing the optimal set of M rocks.

Input

Line 1: Three space-separated integers: LN, and M 
Lines 2.. N+1: Each line contains a single integer indicating how far some rock is away from the starting rock. No two rocks share the same position.

Output

Line 1: A single integer that is the maximum of the shortest distance a cow has to jump after removing M rocks

Sample Input

25 5 2
2
14
11
21
17

Sample Output

4

Hint

Before removing any rocks, the shortest jump was a jump of 2 from 0 (the start) to 2. After removing the rocks at 2 and 14, the shortest required jump is a jump of 4 (from 17 to 21 or from 21 to 25)
 
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<queue>
#include<vector>
#include<cmath>
#include<map>
#include<string>
using namespace std;
#define MAXN 50001
#define INF 0x3f3f3f3f
/*
在一个有序序列中移除M个元素:
    求元素之间最短距离最大能增大多少
先求出当前最短距离
二分查找当前最短-最终最短    找到通过移除M个元素最大的最短距离
关键还是check函数 在移除M个情况下,最短跳跃x能否到达终点
*/
int a[MAXN], L, n, m, tmp;
bool check(int mid)
{
    int i, before = 0, cnt = 0;
    for (i = 1; i <= n + 1; i++)
    {
        if (a[i] - a[before] >= mid)//这块用于判断是否去掉石头
        {
            before = i;
        }
        else
        {
            cnt++;
            if (cnt > m)
                return false;
        }
    }
    return true;
}
int main()
{
    while (scanf("%d%d%d", &L, &n, &m) != EOF)
    {
        a[0] = 0;
        for (int i = 0; i < n; i++)
        {
            scanf("%d", &a[i]);
        }
        a[n+1] = L;
        sort(a, a + n+1);
        int beg = 0, end = L*2,ans = 1;
        while (beg <= end)
        {
            int mid = (beg + end) / 2;
            if (check(mid))
            {
                ans = mid;
                beg = mid + 1;
            }
            else
                end = mid - 1;
        }
        printf("%d\n", ans);
    }
    return 0;
}

 

posted @ 2017-04-13 17:05  joeylee97  阅读(189)  评论(0编辑  收藏  举报