WebService的相关知识
1、在调用Webservice进行数据下发的时候提示“超出最大可接”,一般是因为Webservice设置的接受长度不够导致的;默认接收的最大长度是:4096KB,即4M;可修改Webservice端的配置文件:
<system.web>
<httpRuntime maxRequestLength="2097151" executionTimeout="300" />
</system.web>
maxRequestLength为可接收的最大长度,默认为4096,最大为2097151;executionTimeout 为超时时间,以秒为单位;
2、发布的webservice使用http进行调用的时报异常,导致不能正常访问,默认配置文件中没有下面的内容:
<system.web>
<compilation debug="true" targetFramework="4.0" />
<!--添加对GET、POST的访问支持,缺少该配置时有可能会报错-->
<webServices>
<protocols>
<add name="HttpGet"/>
<add name="HttpPost"/>
<add name="HttpSoap"/>
<add name="Documentation"/>
</protocols>
</webServices>
</system.web>
只需在配置文件的<configuration>下面添加上面代码即可,<compilation debug="true" targetFramework="4.0" />中的framework的版本号根据自己实际项目中使用版本而定,添加上述代码即可正常访问,同时可以通过网页调用相关函数。

浙公网安备 33010602011771号