tensorflow build failed on Centos with Error: suffix or operands invalid for ""

在redhat6.5的机器上编译tensorflow1.10,局部环境配好gcc4.8.2后,发现了如题的错误。这是关于AVX指令集识别问题。虽然gcc版本足够高,能够编出使用AVX的汇编代码,但是binutils版本过低,无法识别汇编里的AVX指令。于是,我源码编译了高版本的binutils。这个问题消失。

但是,编译tf过程中,又出来了glibc版本过低的问题。逻辑上,我在glibc2.12的机器上编出的东西,不该依赖glibc2.14。于是,我觉得是使用了高版本binutils导致的。在机器内核不能升级的情况下,这就产生了矛盾,我目前不会解决。

参考:

https://github.com/tensorflow/serving/issues/431

https://blog.csdn.net/u011334738/article/details/81186345

posted @ 2019-06-14 09:58  jiu~  阅读(378)  评论(0编辑  收藏  举报