HDU 6071 Lazy Running (同余最短路 dij)

Lazy Running

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 524288/524288 K (Java/Others)
Total Submission(s): 1384    Accepted Submission(s): 597


Problem Description
In HDU, you have to run along the campus for 24 times, or you will fail in PE. According to the rule, you must keep your speed, and your running distance should not be less than K meters.

There are 4 checkpoints in the campus, indexed as p1,p2,p3 and p4. Every time you pass a checkpoint, you should swipe your card, then the distance between this checkpoint and the last checkpoint you passed will be added to your total distance.

The system regards these 4 checkpoints as a circle. When you are at checkpoint pi, you can just run to pi1 or pi+1(p1 is also next to p4). You can run more distance between two adjacent checkpoints, but only the distance saved at the system will be counted.




Checkpoint p2 is the nearest to the dormitory, Little Q always starts and ends running at this checkpoint. Please write a program to help Little Q find the shortest path whose total distance is not less than K.
 

 

Input
The first line of the input contains an integer T(1T15), denoting the number of test cases.

In each test case, there are 5 integers K,d1,2,d2,3,d3,4,d4,1(1K1018,1d30000), denoting the required distance and the distance between every two adjacent checkpoints.
 

 

Output
For each test case, print a single line containing an integer, denoting the minimum distance.
 

 

Sample Input
1 2000 600 650 535 380
 

 

Sample Output
2165
Hint
The best path is 2-1-4-3-2.
 

 

Source
【题意】四个点连成环,相邻两个点之间有距离,问从点 1 出发回到点1 ,总距离超过K 的最短路是多少。
【分析】像这种无限走下去的题,可以用同余最短路来解。点1相邻的两条边,设最短的那条长度为,m,那么存在一条长度为x的回到1节点的路,就一定存在长度为x+2*m的路。
  dis[i][j]表示到达i点总长度%2*m==j的最短路,然后dij就行了。
 
#include <bits/stdc++.h>
#define inf 0x3f3f3f3f
#define met(a,b) memset(a,b,sizeof a)
#define pb push_back
#define mp make_pair
#define rep(i,l,r) for(int i=(l);i<=(r);++i)
#define inf 0x3f3f3f3f
using namespace std;
typedef long long ll;
const int N = 6e4+50;;
const int M = 255;
const int mod = 19260817;
const int mo=123;
const double pi= acos(-1.0);
typedef pair<int,int>pii;
typedef pair<ll,int>P;
int n,s;
ll dis[6][N];
ll k,edg[6][6],m,ans;
void dij(int s){
    priority_queue<P,vector<P>,greater<P> >q;
    for(int i=0;i<4;i++){
        for(int j=0;j<=m;j++){
            dis[i][j]=1e18;
        }
    }
    q.push(P(0LL,s));
    while(!q.empty()){
        ll w=q.top().first;
        int u=q.top().second;
        q.pop();
        if(u==s){
            if(w<k){
                ans=min(ans,w+((k-w-1)/m+1)*m);
            }
            else ans=min(ans,w);
        }
        for(int i=0;i<4;i++){
            if(!edg[u][i])continue;
            ll d=w+edg[u][i];
            if(dis[i][d%m]>d){
                dis[i][d%m]=d;
                q.push(P(d,i));
            }
        }
    }
}
int main(){
    int T;
    scanf("%d",&T);
    while(T--){
        ans=1e18;
        scanf("%lld",&k);
        for(int i=0;i<4;i++){
            scanf("%lld",&edg[i][(i+1)%4]);
            edg[(i+1)%4][i]=edg[i][(i+1)%4];
        }
        m=2*min(edg[1][0],edg[1][2]);
        ans=((k-1)/m+1)*m;
        dij(1);
        printf("%lld\n",ans);
    }
    return 0;
}

 

posted @ 2017-09-26 22:48  贱人方  阅读(269)  评论(0编辑  收藏  举报