POJ1149 PIGS (网络流)

                                                                         PIGS
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 20146   Accepted: 9218

Description

Mirko works on a pig farm that consists of M locked pig-houses and Mirko can't unlock any pighouse because he doesn't have the keys. Customers come to the farm one after another. Each of them has keys to some pig-houses and wants to buy a certain number of pigs.
All data concerning customers planning to visit the farm on that particular day are available to Mirko early in the morning so that he can make a sales-plan in order to maximize the number of pigs sold.
More precisely, the procedure is as following: the customer arrives, opens all pig-houses to which he has the key, Mirko sells a certain number of pigs from all the unlocked pig-houses to him, and, if Mirko wants, he can redistribute the remaining pigs across the unlocked pig-houses.
An unlimited number of pigs can be placed in every pig-house.
Write a program that will find the maximum number of pigs that he can sell on that day.

Input

The first line of input contains two integers M and N, 1 <= M <= 1000, 1 <= N <= 100, number of pighouses and number of customers. Pig houses are numbered from 1 to M and customers are numbered from 1 to N.
The next line contains M integeres, for each pig-house initial number of pigs. The number of pigs in each pig-house is greater or equal to 0 and less or equal to 1000.
The next N lines contains records about the customers in the following form ( record about the i-th customer is written in the (i+2)-th line):
A K1 K2 ... KA B It means that this customer has key to the pig-houses marked with the numbers K1, K2, ..., KA (sorted nondecreasingly ) and that he wants to buy B pigs. Numbers A and B can be equal to 0.

Output

The first and only line of the output should contain the number of sold pigs.

Sample Input

3 3
3 1 10
2 1 2 2
2 1 3 3
1 2 6

Sample Output

7
【分析】直接套的书上的标号法模板。
#include <iostream>
#include <cstring>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <time.h>
#include <string>
#include <map>
#include <stack>
#include <vector>
#include <set>
#include <queue>
#define inf 0x3f3f3f3f
#define mod 1000000007
typedef long long ll;
using namespace std;
const int N=105;
const int M=1005;
int s,t,n,m,num,k;
int customer[N][N];
int flow[N][N];
int house[M],last[M];
int pre[N],minflow[N];
void Build() {
    memset(last,0,sizeof(last));
    memset(customer,0,sizeof(customer));
    scanf("%d%d",&m,&n);
    s=0;
    t=n+1;
    for(int i=1; i<=m; i++)scanf("%d",&house[i]);
    for(int i=1; i<=n; i++) {
        scanf("%d",&num);
        for(int j=0; j<num; j++) {
            scanf("%d",&k);
            if(last[k]==0)customer[s][i]+=house[k];
            else customer[last[k]][i]=inf;
            last[k]=i;
        }
        scanf("%d",&customer[i][t]);
    }
}

void BFS() {
    queue<int>q;
    int p=0;
    memset(flow,0,sizeof(flow));
    minflow[0]=inf;
    while(1) {
        while(!q.empty())q.pop();
        for(int i=0; i<N; i++)pre[i]=-2;
        pre[0]=-1;
        q.push(0);
        while(!q.empty()&&pre[t]==-2) {
            int v=q.front();
            q.pop();
            for(int i=0; i<t+1; i++) {
                if(pre[i]==-2&&(p=customer[v][i]-flow[v][i])) {
                    pre[i]=v;
                    q.push(i);
                    minflow[i]=min(p,minflow[v]);
                }
            }
        }
        if(pre[t]==-2)break;
        int j;
        for(int i=pre[t],j=t; i>=0; j=i,i=pre[i]) {
            flow[i][j]+=minflow[t];
            flow[j][i]=-flow[i][j];
        }
    }
    for(int i=0;i<t;i++)p+=flow[i][t];
    printf("%d\n",p);
}
int main() {
    Build();
    BFS();
    return 0;
}
View Code

 

posted @ 2016-08-31 16:06  贱人方  阅读(245)  评论(0编辑  收藏  举报