Hearthstone

                                                                       Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
                                                                                                  Total Submission(s): 1110    Accepted Submission(s): 548

Problem Description
Hearthstone is an online collectible card game from Blizzard Entertainment. Strategies and luck are the most important factors in this game. When you suffer a desperate situation and your only hope depends on the top of the card deck, and you draw the only card to solve this dilemma. We call this "Shen Chou Gou" in Chinese.

Now you are asked to calculate the probability to become a "Shen Chou Gou" to kill your enemy in this turn. To simplify this problem, we assume that there are only two kinds of cards, and you don't need to consider the cost of the cards.
  -A-Card: If the card deck contains less than two cards, draw all the cards from the card deck; otherwise, draw two cards from the top of the card deck.
  -B-Card: Deal X damage to your enemy.

Note that different B-Cards may have different X values.
At the beginning, you have no cards in your hands. Your enemy has P Hit Points (HP). The card deck has N A-Cards and M B-Cards. The card deck has been shuffled randomly. At the beginning of your turn, you draw a card from the top of the card deck. You can use all the cards in your hands until you run out of it. Your task is to calculate the probability that you can win in this turn, i.e., can deal at least P damage to your enemy.

 

 

Input
The first line is the number of test cases T (T<=10). 
Then come three positive integers P (P<=1000), N and M (N+M<=20), representing the enemy’s HP, the number of A-Cards and the number of B-Cards in the card deck, respectively. Next line come M integers representing X (0<X<=1000) values for the B-Cards.
 

 

Output
For each test case, output the probability as a reduced fraction (i.e., the greatest common divisor of the numerator and denominator is 1). If the answer is zero (one), you should output 0/1 (1/1) instead.
 

 

Sample Input
2 3 1 2 1 2 3 5 10 1 1 1 1 1 1 1 1 1 1
 

 

Sample Output
1/3 46/273
 

 

Author
SYSU
 

 

Source
———————————————————————————————————
题目大意: 
牌堆有n张奥术智慧,奥术智慧可以再从牌堆摸两张牌, m张伤害牌,伤害各为xi,初始从牌堆摸一张,问本回合能击杀给定hp的对手的概率,结果用分数表示。(n+m<=20)
思路:数据比较小我们可以想到用状压,dp[x]表示抽了x状态的牌的合法序列的方案数,答案就是Σdp[x]*剩下没抽的牌的全排列/(m+n)的全排列
 
#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <cmath>
#include <map>
#include <set>
#include <stack>
#include <queue>
#include <vector>
#include <bitset>

using namespace std;

#define LL long long
const int INF = 0x3f3f3f3f;
#define MAXN 500

LL dp[1<<21];
LL f[22];
int d[20];
LL gcd(LL x,LL y)
{
    return x?gcd(y%x,x):y;
}

int main()
{
    f[0]=1;
    for(int i=1; i<21; i++)
        f[i]=f[i-1]*i;

    int T,m,n,p;
    for(scanf("%d",&T); T--;)
    {
        scanf("%d%d%d",&p,&n,&m);
        for(int i=0; i<m; i++)
            scanf("%d",&d[i]);
        int N=m+n;
        memset(dp,0,sizeof dp);
        dp[0]=1;
        for(int x=0; x<(1<<N); x++)
        {
            int a=0,b=0,k=0;
            for(int i=0; i<m; i++)
            {
                if(x&(1<<i))
                {
                    k+=d[i];
                    b++;
                }
            }
            if(k>=p) continue;//伤害够了不抽了
            for(int i=m; i<N; i++)
            {
                if(x&(1<<i))
                {
                    a++;
                }
            }
            if(a-b+1<=0) continue;//牌不能再抽了

            for(int i=0;i<N;i++)
            {
                if(x&(1<<i)) continue;
                dp[x^(1<<i)]+=dp[x];//在抽一张的状态数加上现在的状态
            }
        }
        LL ans=0;
        for(int x=0;x<(1<<N);x++)
        {
            if(dp[x]==0) continue;
             int a=0,b=0,k=0;
            for(int i=0; i<m; i++)
            {
                if(x&(1<<i))
                {
                    k+=d[i];
                    b++;
                }
            }
            if(k<p) continue;
            for(int i=m; i<N; i++)
            {
                if(x&(1<<i))
                {
                    a++;
                }
            }
             if(a-b+1<0) continue;
             ans+=dp[x]*f[N-a-b];
        }
        printf("%lld/%lld\n",ans/gcd(ans,f[N]),f[N]/gcd(ans,f[N]));
    }
    return 0;
}