竹山一叶

  博客园 :: 首页 :: 博问 :: 闪存 :: 新随笔 :: 联系 :: 订阅 订阅 :: 管理 ::
  390 随笔 :: 0 文章 :: 0 评论 :: 0 引用
警告:
Not targeting the latest versions of Android; compatibility modes apply.
Consider testing and updating this version. Consult the android.os.Build.VERSION_CODES javadoc for details.

 ANDROID SDK 版本是19.


<?xml version="1.0" encoding="utf-8"?><manifest xmlns:android="http://schemas.android.com/apk/res/android"
    package="com.example.themetest"
    android:versionCode="1"
    android:versionName="1.0" ><uses-sdk
        android:minSdkVersion="8"
        android:targetSdkVersion="16" />                  问题在这里
<application
        android:allowBackup="true"
        android:icon="@drawable/ic_launcher"
        android:label="@string/app_name"
        android:theme="@style/AppBaseTheme" ><activity
            android:name="com.example.themetest.MainActivity"
            android:label="@string/app_name" ><intent-filter><action android:name="android.intent.action.MAIN" /><category android:name="android.intent.category.LAUNCHER" /></intent-filter></activity></application></manifest>

解决:targetSdkVersion版本不是最新的,改成本地SDK的最新或更新就好了。

本地是19


<uses-sdk
        android:minSdkVersion="4"
        android:targetSdkVersion="19" />

或者

<uses-sdk
        android:minSdkVersion="4"
        android:targetSdkVersion="30" />

 参考:http://stackoverflow.com/questions/13431722/not-targeting-the-latest-versions-of-android


来源:http://www.cnblogs.com/javadu/p/3812509.html





posted on 2017-06-19 13:12 竹山一叶 阅读(...) 评论(...) 编辑 收藏