[转]NVIDIA-SMI has failed because it couldn't communicate with the NVIDIA driver

转自 https://blog.csdn.net/Felaim/article/details/100516282

只截取其中用过的一种方法:

因为Linux更新都是为了修复之前内核的bug,提供一些新的特性,如果一直使用比较旧的内核,还是治标不治本,所以LZ有找到了一种方法,在使用新内核的同时,也不用重新安装驱动,具体方法如下:

Step 1: 安装DKMS
DKMS全称是DynamicKernel ModuleSupport,它可以帮我们维护内核外的驱动程序,在内核版本变动之后可以自动重新生成新的模块。在使用dkms之前首先需要确保系统中已经安装了DKMS,在Ubuntu下可以执行下面这个命令安装。
sudo apt-get install dkms
通过
cd /usr/src
然后ls一下,查看你对应安装的驱动版本

可以看到LZ这已经有三个版本的内核了,nvidia-smi的版本是430.34.

step2. 重新生成对应nvidia的驱动模块

step2: sudo dkms install -m nvidia -v 430.34

后面进行检验可以看到LZ用了最新的内核,也可以nvidia-smi. So, problem solved!
————————————————
版权声明:本文为CSDN博主「Felaim」的原创文章,遵循 CC 4.0 BY-SA 版权协议,转载请附上原文出处链接及本声明。
原文链接:https://blog.csdn.net/Felaim/article/details/100516282

posted @ 2020-03-02 14:19  过客冲冲  阅读(965)  评论(0编辑  收藏  举报