杭电--1875--畅通工程再续--并查集

畅通工程再续

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 10216    Accepted Submission(s): 3113


Problem Description
相信大家都听说一个“百岛湖”的地方吧,百岛湖的居民生活在不同的小岛中,当他们想去其他的小岛时都要通过划小船来实现。现在政府决定大力发展百岛湖,发展首先要解决的问题当然是交通问题,政府决定实现百岛湖的全畅通!经过考察小组RPRush对百岛湖的情况充分了解后,决定在符合条件的小岛间建上桥,所谓符合条件,就是2个小岛之间的距离不能小于10米,也不能大于1000米。当然,为了节省资金,只要求实现任意2个小岛之间有路通即可。其中桥的价格为 100元/米。
 


 

Input
输入包括多组数据。输入首先包括一个整数T(T <= 200),代表有T组数据。
每组数据首先是一个整数C(C <= 100),代表小岛的个数,接下来是C组坐标,代表每个小岛的坐标,这些坐标都是 0 <= x, y <= 1000的整数。
 


 

Output
每组输入数据输出一行,代表建桥的最小花费,结果保留一位小数。如果无法实现工程以达到全部畅通,输出”oh!”.
 


 

Sample Input
2 2 10 10 20 20 3 1 1 2 2 1000 1000
 


 

Sample Output
1414.2 oh!

 

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cmath>
using namespace std;
int father[111];
double s;
struct ssss
{
 double a,b;
}ss[111];
struct road
{
 int a,b;
 double x;
}rr[5000];
int Find(int a)
{
 return a==father[a]?a:father[a]=Find(father[a]);
}
void Union(int i)
{
 int a=Find(rr[i].a),b=Find(rr[i].b);
 if(a!=b&&rr[i].x<=1000&&rr[i].x>=10) //非同族且距离不大于1000不小于10
  father[a]=b,s+=rr[i].x;
}
bool cmp(const road &a,const road &b)
{
 return a.x<b.x;
}
int main (void)
{
 int t,n,m,i,j,k,l;
 cin>>t;
 while(t--&&cin>>n)
 {
  m=n*(n-1)/2;
  for(i=0;i<1111;i++)father[i]=i;
  for(i=1;i<=n;i++)
   cin>>ss[i].a>>ss[i].b;  //ss数组用来记录每个岛的坐标
  for(i=1,l=0;i<=n;i++)
   for(j=i+1;j<=n;j++)
   {
    rr[l].a=i;rr[l].b=j;  //rr用a和b记录两个岛
    double x=ss[i].a-ss[j].a,y=ss[i].b-ss[j].b;
    rr[l].x=sqrt(x*x+y*y);  //x用来记录两岛之间的距离****关键---转化问题
    l++;
   }
  sort(rr,rr+l,cmp);  //按照距离排序
  for(i=s=0;i<l;i++)
   Union(i);
  for(i=1,k=0;i<=n&&k<2;i++)
   if(father[i]==i)k++; //用k标记是否连通了
   if(k>=2)cout<<"oh!"<<endl;
   else printf("%.1f\n",s*100);
 }
 return 0;
}

 

posted @ 2013-07-19 18:25  javawebsoa  Views(214)  Comments(0Edit  收藏  举报