POJ 2049 Finding Nemo

Finding Nemo
Time Limit: 2000MS   Memory Limit: 30000K
Total Submissions: 6985   Accepted: 1598

Description

Nemo is a naughty boy. One day he went into the deep sea all by himself. Unfortunately, he became lost and couldn't find his way home. Therefore, he sent a signal to his father, Marlin, to ask for help. 
After checking the map, Marlin found that the sea is like a labyrinth with walls and doors. All the walls are parallel to the X-axis or to the Y-axis. The thickness of the walls are assumed to be zero. 
All the doors are opened on the walls and have a length of 1. Marlin cannot go through a wall unless there is a door on the wall. Because going through a door is dangerous (there may be some virulent medusas near the doors), Marlin wants to go through as few doors as he could to find Nemo. 
Figure-1 shows an example of the labyrinth and the path Marlin went through to find Nemo. 

We assume Marlin's initial position is at (0, 0). Given the position of Nemo and the configuration of walls and doors, please write a program to calculate the minimum number of doors Marlin has to go through in order to reach Nemo.

Input

The input consists of several test cases. Each test case is started by two non-negative integers M and N. M represents the number of walls in the labyrinth and N represents the number of doors. 
Then follow M lines, each containing four integers that describe a wall in the following format: 
x y d t 
(x, y) indicates the lower-left point of the wall, d is the direction of the wall -- 0 means it's parallel to the X-axis and 1 means that it's parallel to the Y-axis, and t gives the length of the wall. 
The coordinates of two ends of any wall will be in the range of [1,199]. 
Then there are N lines that give the description of the doors: 
x y d 
x, y, d have the same meaning as the walls. As the doors have fixed length of 1, t is omitted. 
The last line of each case contains two positive float numbers: 
f1 f2 
(f1, f2) gives the position of Nemo. And it will not lie within any wall or door. 
A test case of M = -1 and N = -1 indicates the end of input, and should not be processed.

Output

For each test case, in a separate line, please output the minimum number of doors Marlin has to go through in order to rescue his son. If he can't reach Nemo, output -1.

Sample Input

8 9
1 1 1 3
2 1 1 3
3 1 1 3
4 1 1 3
1 1 0 3
1 2 0 3
1 3 0 3
1 4 0 3
2 1 1
2 2 1
2 3 1
3 1 1
3 2 1
3 3 1
1 2 0
3 3 0
4 3 1
1.5 1.5
4 0
1 1 0 1
1 1 1 1
2 1 1 1
1 2 0 1
1.5 1.7
-1 -1

Sample Output

5
-1

Source

 

用每个方格的坐下标表示每个方格,

#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>

using namespace std;

const int N=250;
const int INF=0x3f3f3f3f;

struct node{
    int x,y;
    int door;
    bool operator < (const node &a) const{
        return a.door<door;
    }
};

int n,m,sx,sy,maxx,maxy;
int dis[N][N],h[N][N],l[N][N];

void BFS(){
    priority_queue<node> q;
    while(!q.empty())
        q.pop();
    for(int i=0;i<=maxx;i++)
        for(int j=0;j<=maxy;j++)
            dis[i][j]=INF;
    node cur;
    cur.x=0,    cur.y=0,    cur.door=0;
    dis[0][0]=0;
    q.push(cur);
    while(!q.empty()){
        cur=q.top();
        q.pop();
        int x=cur.x,    y=cur.y;
        if(x==sx && y==sy)
            return ;
        if(y+1<=maxy && dis[x][y+1]>dis[x][y]+h[x][y+1]){  //向上走
            dis[x][y+1]=dis[x][y]+h[x][y+1];
            cur.x=x;
            cur.y=y+1;
            cur.door=dis[x][y+1];
            q.push(cur);
        }
        if(y-1>=0 && dis[x][y-1]>dis[x][y]+h[x][y]){   //向下走
            dis[x][y-1]=dis[x][y]+h[x][y];
            cur.x=x;
            cur.y=y-1;
            cur.door=dis[x][y-1];
            q.push(cur);
        }
        if(x-1>=0 && dis[x-1][y]>dis[x][y]+l[x][y]){  //向左走
            dis[x-1][y]=dis[x][y]+l[x][y];
            cur.x=x-1;
            cur.y=y;
            cur.door=dis[x-1][y];
            q.push(cur);
        }
        if(x+1<=maxx && dis[x+1][y]>dis[x][y]+l[x+1][y]){     //向右走
            dis[x+1][y]=dis[x][y]+l[x+1][y];
            cur.x=x+1;
            cur.y=y;
            cur.door=dis[x+1][y];
            q.push(cur);
        }
    }
    dis[sx][sy]=-1;
}
int main(){

    //freopen("input.txt","r",stdin);

    int x,y,d,t;
    double f1,f2;
    while(~scanf("%d%d",&n,&m)){
        if(n==-1 && m==-1)
            break;
        maxx=-1,    maxy=-1;
        memset(h,0,sizeof(h));
        memset(l,0,sizeof(l));
        while(n--){
            scanf("%d%d%d%d",&x,&y,&d,&t);
            if(d==0){
                for(int i=0;i<t;i++)
                    h[x+i][y]=INF;
                maxx=max(maxx,x+t);
                maxy=max(maxy,y);
            }else{
                for(int i=0;i<t;i++)
                    l[x][y+i]=INF;
                maxx=max(maxx,x);
                maxy=max(maxy,y+t);
            }
        }
        while(m--){
            scanf("%d%d%d",&x,&y,&d);
            if(d==0)
                h[x][y]=1;
            else
                l[x][y]=1;
        }
        scanf("%lf%lf",&f1,&f2);
        if(f1>maxx || f2>maxy){
            puts("0");
            continue;
        }
        sx=(int)f1,     sy=(int)f2;
        BFS();
        printf("%d\n",dis[sx][sy]);
    }
    return 0;
}

 

posted @ 2013-08-13 10:35  Jack Ge  阅读(1036)  评论(0编辑  收藏  举报