POJ 1862 Stripies (哈夫曼树)

Stripies
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 10263   Accepted: 4971

Description

Our chemical biologists have invented a new very useful form of life called stripies (in fact, they were first called in Russian - polosatiki, but the scientists had to invent an English name to apply for an international patent). The stripies are transparent amorphous amebiform creatures that live in flat colonies in a jelly-like nutrient medium. Most of the time the stripies are moving. When two of them collide a new stripie appears instead of them. Long observations made by our scientists enabled them to establish that the weight of the new stripie isn't equal to the sum of weights of two disappeared stripies that collided; nevertheless, they soon learned that when two stripies of weights m1 and m2 collide the weight of resulting stripie equals to 2*sqrt(m1*m2). Our chemical biologists are very anxious to know to what limits can decrease the total weight of a given colony of stripies. 
You are to write a program that will help them to answer this question. You may assume that 3 or more stipies never collide together. 

Input

The first line of the input contains one integer N (1 <= N <= 100) - the number of stripies in a colony. Each of next N lines contains one integer ranging from 1 to 10000 - the weight of the corresponding stripie.

Output

The output must contain one line with the minimal possible total weight of colony with the accuracy of three decimal digits after the point.

Sample Input

3
72
30
50

Sample Output

120.000

Source

Northeastern Europe 2001, Northern Subregion

 

题意:即给你一定的生物,他们会有一定的重量,如果他们相互碰撞,    那么根据题目给的那个公式2*sqrt(m1*m2) ,质量会减少。

           这个公式表示的是两个物品质量分别为m1m2,而他们碰撞后的总质量会减少为2*sqrt(m1*m2) 

           给你一定的这样的生物及它们的质量,要你求它们经过碰撞后的最小总质量。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>
#include<cmath>
#include<algorithm>

using namespace std;

int n;

int main(){

    //freopen("input.txt","r",stdin);

    priority_queue<double> q;
    while(~scanf("%d",&n)){
        while(!q.empty())
            q.pop();
        double x,a,b;
        for(int i=0;i<n;i++){
            scanf("%lf",&x);
            q.push(x);
        }
        while(q.size()>1){
            a=q.top();  q.pop();
            b=q.top();  q.pop();
            x=2*sqrt(a*b);
            q.push(x);
        }
        printf("%.3f\n",q.top());
    }
    return 0;
}

 

其实就是贪心的思想:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>
#include<cstdlib>
#include<cmath>
#include<algorithm>

using namespace std;

int n;
double num[110];

int cmp(double a,double b){
    return a>b;
}

int main(){

    //freopen("input.txt","r",stdin);

    while(~scanf("%d",&n)){
        for(int i=0;i<n;i++)
            scanf("%lf",&num[i]);
        sort(num,num+n,cmp);
        double ans=num[0];
        for(int i=1;i<n;i++)    //ans始终为最大的,因为2*sqrt(a*b),a,b都是最大的,所以ans使最大的
            ans=2*sqrt(ans*num[i]);
        printf("%.3f\n",ans);
    }
    return 0;
}

 

posted @ 2013-07-29 15:45  Jack Ge  阅读(1031)  评论(0编辑  收藏  举报