POJ 2499 Binary Tree

Binary Tree
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 5399   Accepted: 2502

Description

Background 
Binary trees are a common data structure in computer science. In this problem we will look at an infinite binary tree where the nodes contain a pair of integers. The tree is constructed like this: 
  • The root contains the pair (1, 1). 
  • If a node contains (a, b) then its left child contains (a + b, b) and its right child (a, a + b)

Problem 
Given the contents (a, b) of some node of the binary tree described above, suppose you are walking from the root of the tree to the given node along the shortest possible path. Can you find out how often you have to go to a left child and how often to a right child?

Input

The first line contains the number of scenarios. 
Every scenario consists of a single line containing two integers i and j (1 <= i, j <= 2*109) that represent 
a node (i, j). You can assume that this is a valid node in the binary tree described above.

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing two numbers l and r separated by a single space, where l is how often you have to go left and r is how often you have to go right when traversing the tree from the root to the node given in the input. Print an empty line after every scenario.

Sample Input

3
42 1
3 4
17 73

Sample Output

Scenario #1:
41 0

Scenario #2:
2 1

Scenario #3:
4 6

Source

 
刚开始想用DFS,后来试试,,不太行,。。。。。。。。。。后来感觉类似辗转相除法,,恩,果然可行
 
#include<iostream>
#include<cstdio>
#include<cstring>

using namespace std;

int main(){

    //freopen("input.txt","r",stdin);

    int l,r;
    int t,cases=0;
    scanf("%d",&t);
    while(t--){
        scanf("%d%d",&l,&r);
        int a=0,b=0;
        while(l!=1 || r!=1){
            if(l>r){
                a+=(l-1)/r;     //这里减一是为了避免下面式子相减之后为 0
                l-=(l-1)/r*r;
            }else{
                b+=(r-1)/l;
                r-=(r-1)/l*l;
            }
        }
        printf("Scenario #%d:\n",++cases);
        printf("%d %d\n\n",a,b);
    }
    return 0;
}

 

posted @ 2013-06-16 18:43  Jack Ge  阅读(301)  评论(0编辑  收藏  举报