HDU 1503 Advanced Fruits (最长公共子序列)

Advanced Fruits

http://acm.hdu.edu.cn/showproblem.php?pid=1503

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 977 Accepted Submission(s): 466
Special Judge


Problem Description
The company "21st Century Fruits" has specialized in creating new sorts of fruits by transferring genes from one fruit into the genome of another one. Most times this method doesn't work, but sometimes, in very rare cases, a new fruit emerges that tastes like a mixture between both of them.
A big topic of discussion inside the company is "How should the new creations be called?" A mixture between an apple and a pear could be called an apple-pear, of course, but this doesn't sound very interesting. The boss finally decides to use the shortest string that contains both names of the original fruits as sub-strings as the new name. For instance, "applear" contains "apple" and "pear" (APPLEar and apPlEAR), and there is no shorter string that has the same property.

A combination of a cranberry and a boysenberry would therefore be called a "boysecranberry" or a "craboysenberry", for example.

Your job is to write a program that computes such a shortest name for a combination of two given fruits. Your algorithm should be efficient, otherwise it is unlikely that it will execute in the alloted time for long fruit names.
 

 

Input
Each line of the input contains two strings that represent the names of the fruits that should be combined. All names have a maximum length of 100 and only consist of alphabetic characters.

Input is terminated by end of file.
 

 

Output
For each test case, output the shortest name of the resulting fruit on one line. If more than one shortest name is possible, any one is acceptable.
 

 

Sample Input
 
apple peach
ananas banana
pear peach
 

 

Sample Output
 
appleach
bananas
pearch
 

 

Source
 

 

Recommend
linle
 
 
#include<iostream>
#include<cstdio>
#include<cstring>

using namespace std;

char str1[110],str2[110];
int dp[110][110];   //最长公共子序列

struct node{
    int i,j;    //记录str1和str2的相同字符在原字符串中的相应位置
    char ch;    //记录该相同字符,方便后面输出
}res[210];

int main(){

    //freopen("input.txt","r",stdin);

    while(~scanf("%s%s",str1+1,str2+1)){
        memset(dp,0,sizeof(dp));
        int len1=strlen(str1+1);
        int len2=strlen(str2+1);
        for(int i=1;i<=len1;i++)
            for(int j=1;j<=len2;j++)
                if(str1[i]==str2[j])
                    dp[i][j]=dp[i-1][j-1]+1;
                else
                    dp[i][j]=max(dp[i-1][j],dp[i][j-1]);
        //printf("%d\n",dp[len1][len2]);
        if(dp[len1][len2]==0){
            printf("%s%s\n",str1,str2);
            continue;
        }
        int i=len1,j=len2,cnt=0;
        while(i>0 && j>0){
            if(dp[i][j]==dp[i-1][j-1]+1 && str1[i]==str2[j]){
                res[cnt].i=i;
                res[cnt].j=j;
                res[cnt++].ch=str1[i];
                i--;    j--;
            }else if(dp[i-1][j]>dp[i][j-1])     //dp[i-1][j]>dp[i][j-1]>=dp[i-1][j-1],你懂得,为了达到dp[i][j]==dp[i-1][j-1],故i--,下同
                i--;
            else
                j--;
        }
        i=1,j=1;
        for(int k=cnt-1;k>=0;k--){
            while(i<=len1 && str1[i]!=res[k].ch){
                printf("%c",str1[i]);
                i++;
            }
            while(j<=len2 && str2[j]!=res[k].ch){
                printf("%c",str2[j]);
                j++;
            }
            printf("%c",res[k].ch);
            i++;j++;
        }
        printf("%s%s\n",str1+i,str2+j);     //输出str1,str2剩余的未匹配的所有字符
    }
    return 0;
}

 

 

posted @ 2013-01-05 21:27  Jack Ge  阅读(432)  评论(0编辑  收藏  举报