Problem Description

FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.

Input

The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000.

Output

For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.

Sample Input

5 3
7 2
4 3
5 2
20 3
25 18
24 15
15 10
-1 -1

Sample Output

13.333
31.500


【题意】一只老鼠有n的猫粮,一只猫有m间房,每间房有num的豆需要val的猫粮换取,求最大能换到的豆
【思路】简单的贪心问题

 

#include<iostream>
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
const int N=1000+10;
int n,m;
struct node
{
    double num;
    double val;
    double p;
}a[N];
bool cmp(node a,node b)
{
    return a.p>b.p;
}
int main()
{
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        if(m==-1&&n==-1) break;
        for(int i=1;i<=m;i++)
        {
            scanf("%lf%lf",&a[i].num,&a[i].val);
            a[i].p=1.0*a[i].num/a[i].val;

        }
        sort(a+1,a+m+1,cmp);
        double ans=0;
        for(int i=1;i<=m;i++)
        {
            if(n==0) break;

            if(a[i].val<=n)
            {
                n-=a[i].val;
                ans+=a[i].num;
            }
            else
            {
                ans+=1.0*n*a[i].p;
                break;
            }
        }
        printf("%.3lf\n",ans);
    }
    return 0;
}