Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65535/65535K (Java/Other)
Total Submission(s) : 9   Accepted Submission(s) : 8

Font: Times New Roman | Verdana | Georgia

Font Size: ← →

Problem Description

Alice and Bob are playing a game. There are two piles of cards. There are N cards in each pile, and each card has a score. They take turns to pick up the top or bottom card from either pile, and the score of the card will be added to his total score. Alice and Bob are both clever enough, and will pick up cards to get as many scores as possible. Do you know how many scores can Alice get if he picks up first?

Input

The first line contains an integer T (T≤100), indicating the number of cases. 
Each case contains 3 lines. The first line is the N (N≤20). The second line contains N integer ai (1≤ai≤10000). The third line contains N integer bi (1≤bi≤10000).

Output

For each case, output an integer, indicating the most score Alice can get.

Sample Input

2 
 
1 
23 
53 
 
3 
10 100 20 
2 4 3 

Sample Output

53 
105 
dp[i,j,k,h]表示还剩下第一堆[i,j],第二堆[k,h]最多能拿多少
你有四种选择:
1. 选择第一行的最左边数字  dp(i+1, j, k, h)
2. 选择第一行的最右边数字   dp(i, j-1, k, h)
3. 选择第二行的最左边数字  dp(i, j, k+1, h)
4. 选择第二行的最右边数字   dp(i, j, k, h-1)

然后sum-(Alice上一个状态中Bob拿的值)中取最大
#include<iostream>
#include<string.h>
using namespace std;
const int N=25;
int n,dp[N][N][N][N],a[N],b[N];
int solve(int x1,int y1,int x2,int y2,int sum)
{
    int maxn=0;
    if(x1>y1&&x2>y2) return 0;
    if(dp[x1][y1][x2][y2]) return dp[x1][y1][x2][y2];
    if(x1<=y1)
    {
        maxn=max(maxn,sum-solve(x1+1,y1,x2,y2,sum-a[x1]));
        maxn=max(maxn,sum-solve(x1,y1-1,x2,y2,sum-a[y1]));
    }
    if(x2<=y2)
    {
        maxn=max(maxn,sum-solve(x1,y1,x2+1,y2,sum-b[x2]));
        maxn=max(maxn,sum-solve(x1,y1,x2,y2-1,sum-b[y2]));
    }
    dp[x1][y1][x2][y2]=maxn;
    return maxn;
}

int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        int sum=0;
        cin>>n;
        for(int i=1;i<=n;i++)
        {
             cin>>a[i];
             sum+=a[i];
        }
        for(int i=1;i<=n;i++)
        {
            cin>>b[i];
            sum+=b[i];
        }
        memset(dp,0,sizeof(dp));
        int ans=solve(1,n,1,n,sum);
        cout<<ans<<endl;
    }
    return 0;
}