Oozie的Log报错unknown hadoop job,可是RM显示任务执行成功

昨天下午跑Oozie Job的时候Job Log报如下错误:

org.apache.oozie.action.ActionExecutorException: JA017: Unknown hadoop job [job_1402629939350_0001] associated with action [0000000-140612202641089-oozie-oozi-W@mr-node]. Failing this action!

接着打开Resouce Manager的Web UI,显示两个Job都是SUCCEEDED状态,这下没头绪了。晚上回家想起来赶紧FQ查查,果然国外有可借鉴的帖子,先Mark一下待周一回公司证实,原帖地址:https://support.gopivotal.com/hc/en-us/articles/202530283-Oozie-logs-report-Unknown-hadoop-job-and-history-server-UI-not-populated

简单来说,可能引起这个错误的原因是Node Manager中的yarn-site.xml和Resouce Manager中的maperd-site.xml中,参数mapreduce.jobhistory.intermediate-done-dir配置的目录不一样,导致JobHistory Server读不到日志。而当Job执行完毕后,Oozie需要根据JobHistory Server的日志,决定Oozie workflow状态的流转,没有日志的话流程就自动转到Failed了。

posted @ 2014-07-12 09:42  IRIS我的天使  阅读(1002)  评论(0)    收藏  举报