centos7安装python3.6后导致防火墙功能无法正常工作的解决办法

问题:因为默认python版本被设置成了python3.6,而进行防火墙的指令操作频频报错。

Jul 19 16:30:51 localhost.localdomain systemd[1]: Starting firewalld - dynamic firewall daemon...
Jul 19 16:30:51 localhost.localdomain systemd[1]: firewalld.service: main process exited, code=exited, status=1/FAILURE
Jul 19 16:30:51 localhost.localdomain systemd[1]: Failed to start firewalld - dynamic firewall daemon.
Jul 19 16:30:51 localhost.localdomain systemd[1]: Unit firewalld.service entered failed state.
Jul 19 16:30:51 localhost.localdomain systemd[1]: firewalld.service failed.

原因:centos7 里面装了Python2.7  和 Python(其他) 两个版本,执行firewall-cmd 系列的命令的时候回运行Python文件结果Python文件的头 #!/usr/bin/python 

都不会再python2.7 里面运行。

解决方法:文件头田间 2.7即可

1.修改  vi /usr/bin/firewall-cmd  文件头添加 2.7

2.  vi /usr/sbin/firewalld 添加 2.7

验证:systemctl status firewalld.service

 

参考:

https://www.jianshu.com/p/a538125371d4

 

本文版权归作者所有,转载请注明出处http://www.cnblogs.com/iloverain/.未经作者同意必须保留此段声明,否则保留追究法律责任的权利.
posted @ 2018-07-19 17:53  Code~Rush  阅读(365)  评论(0编辑  收藏  举报