Loading...

mac上eclipse提示version 11 or greater is required

解决方案

  • 打开访达->应用程序->Eclipse->右键->显示包数据->Eclipse->eclipse.ini

  • 将 -Dosgi.requiredJavaVersion从11改为1.8.0_211

  • 将 -Dosgi.requiredJavaVersion从11改为1.8.0_211

你的jdk版本不一定是1.8.0_211,用java -version查看

-startup
../Eclipse/plugins/org.eclipse.equinox.launcher_1.5.800.v20200727-1323.jar
--launcher.library
../Eclipse/plugins/org.eclipse.equinox.launcher.cocoa.macosx.x86_64_1.1.1300.v20200819-0940
-product
org.eclipse.epp.package.committers.product
-showsplash
org.eclipse.epp.package.common
--launcher.defaultAction
openFile
--launcher.defaultAction
openFile
--launcher.appendVmargs
-vmargs
-Dosgi.requiredJavaVersion=1.8.0_211
-Dosgi.instance.area.default=@user.home/code/java
-XX:+UseG1GC
-XX:+UseStringDeduplication
--add-modules=ALL-SYSTEM
-XstartOnFirstThread
-Dorg.eclipse.swt.internal.carbon.smallFonts
-Dosgi.requiredJavaVersion=1.8.0_211
-Dosgi.dataAreaRequiresExplicitInit=true
-Xms256m
-Xmx2048m
--add-modules=ALL-SYSTEM
-Xdock:icon=../Resources/Eclipse.icns
-XstartOnFirstThread
-Dorg.eclipse.swt.internal.carbon.smallFonts
posted @ 2020-11-12 14:49  awesomego  阅读(1023)  评论(0编辑  收藏  举报