win10下多版本apache(2.2,2.4)+php(5.3.5,5.5.37,5.6.25,7.0.8)注意点

1.Loaded Configuration File 问题:

apache2.2 httpd

PHPIniDir D:\php5.3.5\php.ini
AddType application/x-httpd-php .php .html .htm
LoadModule php5_module D:/php5.3.5/php5apache2_2.dll

apache2.4 httpd

#解决curl问题
LoadFile D:/php-7.0.8/php7ts.dll
LoadFile D:/php-7.0.8/libeay32.dll
LoadFile D:/php-7.0.8/ssleay32.dll
LoadFile D:/php-7.0.8/libssh2.dll

# php5.5 support
#LoadModule php5_module D:/php-5.5.37/php5apache2_4.dll
#AddType application/x-httpd-php .php .html .htm
# configure thepath to php.ini
#PHPIniDir "D:/php-5.5.37"

# php5.6 support
#LoadModule php5_module D:/php-5.6.25/php5apache2_4.dll
#AddType application/x-httpd-php .php .html .htm
# configure thepath to php.ini
#PHPIniDir "D:/php-5.6.25"

# php7 support
LoadModule php7_module D:/php-7.0.8/php7apache2_4.dll
AddType application/x-httpd-php .php .html .htm
# configure thepath to php.ini
PHPIniDir "D:/php-7.0.8"

2 一些相关命令(管理员权限)

cd d:\apache22
httpd  –k install
httpd  –k start
httpd  –k stop
httpd -S

sc delete apache2.2
posted @ 2017-05-16 02:59 ikoDotA 阅读(...) 评论(...) 编辑 收藏
ikoDotA's 新浪微博