POJ1002 SDUT1001 487-3279 ACM算法设计

487-3279

Time Limit: 2000MS Memory limit: 65536K

题目描述

Businesses like to have memorable telephone numbers. One way to make a telephone number memorable is to have it spell a memorable word or phrase. For example, you can call the University of Waterloo by dialing the memorable TUT-GLOP. Sometimes only part of the number is used to spell a word. When you get back to your hotel tonight you can order a pizza from Gino's by dialing 310-GINO. Another way to make a telephone number memorable is to group the digits in a memorable way. You could order your pizza from Pizza Hut by calling their ``three tens'' number 3-10-10-10. 

The standard form of a telephone number is seven decimal digits with a hyphen between the third and fourth digits (e.g. 888-1200). The keypad of a phone supplies the mapping of letters to numbers, as follows: 

A, B, and C map to 2 
D, E, and F map to 3 
G, H, and I map to 4 
J, K, and L map to 5 
M, N, and O map to 6 
P, R, and S map to 7 
T, U, and V map to 8 
W, X, and Y map to 9 

There is no mapping for Q or Z. Hyphens are not dialed, and can be added and removed as necessary. The standard form of TUT-GLOP is 888-4567, the standard form of 310-GINO is 310-4466, and the standard form of 3-10-10-10 is 310-1010. 

Two telephone numbers are equivalent if they have the same standard form. (They dial the same number.) 

Your company is compiling a directory of telephone numbers from local businesses. As part of the quality control process you want to check that no two (or more) businesses in the directory have the same telephone number.

输入

The input will consist of one case. The first line of the input specifies the number of telephone numbers in the directory (up to 100,000) as a positive integer alone on the line. The remaining lines list the telephone numbers in the directory, with each number alone on a line. Each telephone number consists of a string composed of decimal digits, uppercase letters (excluding Q and Z) and hyphens. Exactly seven of the characters in the string will be digits or letters.

输出

Generate a line of output for each telephone number that appears more than once in any form. The line should give the telephone number in standard form, followed by a space, followed by the number of times the telephone number appears in the directory. Arrange the output lines by telephone number in ascending lexicographical order. If there are no duplicates in the input print the line: 

No duplicates.

示例输入

12
4873279
ITS-EASY
888-4567
3-10-10-10
888-GLOP
TUT-GLOP
967-11-11
310-GINO
F101010
888-1200
-4-8-7-3-2-7-9-
487-3279

示例输出

310-1010 2
487-3279 4
888-4567 3
URL:
 
简单的字符串题目,但是却坑了我5个小时。。
#include<iostream>
#include<algorithm>
//#include <fstream>
#include <vector>
#include<string>
using namespace std;
char arr[]={'2','2','2','3','3','3','4','4','4','5','5','5','6','6','6','7','0','7','7','8','8','8','9','9','9','0'};
int main()
{
	//ifstream cin("in.txt");	
	vector<string> vs;
	int n;
	cin>>n;
	string s;
	//输入,输入过程中去掉‘-’,并且将字母转换为数字
	for(int i = 0;i <= n;i++)//注意这个地方是 i<=n ,没错,不这么写就给你Wrong Answer,就这个地方坑了我5个小时,坑不?
	{
		string temp;
		getline(cin,s);
		for(int j = 0;j != s.size();j++)
		{
			if(s[j]>='0'&&s[j]<='9')temp.push_back(s[j]);
			else if(s[j]>='A'&&s[j]<='Z')temp.push_back(arr[s[j]-'A']);
		}
		vs.push_back(temp);
	}
	//从小到大排序
	sort(vs.begin(),vs.end());
	bool IsNoans = true;
	int repeatCount = 1;
	//检索想同的串并输出
	for(int i = 1;i < vs.size();i ++)
	{
		if(vs[i] == vs[i-1])
			repeatCount ++;
		else if(repeatCount > 1)
		{
			cout<<vs[i-1][0]<<vs[i-1][1]<<vs[i-1][2]<<"-"<<vs[i-1][3]<<vs[i-1][4]<<vs[i-1][5]<<vs[i-1][6]<<" "<<repeatCount<<endl;
			if(IsNoans) IsNoans = false;
			repeatCount = 1;
		}
	}
	//上面for循环会漏掉一种情况:当数组中最后一个串和其前面的串相等时,最后的串不会输出,所以输出他
	if(repeatCount > 1)
	{
		cout<<vs[vs.size()-1][0]<<vs[vs.size()-1][1]<<vs[vs.size()-1][2]<<"-"<<vs[vs.size()-1][3]<<vs[vs.size()-1][4]<<vs[vs.size()-1][5]<<vs[vs.size()-1][6]<<" "<<repeatCount<<endl;
		if(IsNoans) IsNoans = false;
	}
	//没有输出过,即没有相同的电话号码
	if(IsNoans) cout<<"No duplicates."<<endl;
	return 0;
}

 

posted @ 2013-04-10 08:19  iFinVer  阅读(177)  评论(0编辑  收藏  举报