poj 2262 Goldbach's Conjecture 素数 水题

Language:
Goldbach's Conjecture
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 38134   Accepted: 14673

Description

In 1742, Christian Goldbach, a German amateur mathematician, sent a letter to Leonhard Euler in which he made the following conjecture: 
Every even number greater than 4 can be 
written as the sum of two odd prime numbers.

For example: 
8 = 3 + 5. Both 3 and 5 are odd prime numbers. 
20 = 3 + 17 = 7 + 13. 
42 = 5 + 37 = 11 + 31 = 13 + 29 = 19 + 23.

Today it is still unproven whether the conjecture is right. (Oh wait, I have the proof of course, but it is too long to write it on the margin of this page.) 
Anyway, your task is now to verify Goldbach's conjecture for all even numbers less than a million. 

Input

The input will contain one or more test cases. 
Each test case consists of one even integer n with 6 <= n < 1000000. 
Input will be terminated by a value of 0 for n.

Output

For each test case, print one line of the form n = a + b, where a and b are odd primes. Numbers and operators should be separated by exactly one blank like in the sample output below. If there is more than one pair of odd primes adding up to n, choose the pair where the difference b - a is maximized. If there is no such pair, print a line saying "Goldbach's conjecture is wrong."

Sample Input

8
20
42
0

Sample Output

8 = 3 + 5
20 = 3 + 17
42 = 5 + 37

Source

题意:任意一个大于四的偶数都可以写成两个奇素数的和。

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <string>
#include <map>
#include <stack>
#include <vector>
#include <set>
#include <queue>
#pragma comment (linker,"/STACK:102400000,102400000")
#define maxn 1000005
#define MAXN 2005
#define mod 1000000009
#define INF 0x3f3f3f3f
#define pi acos(-1.0)
#define eps 1e-6
typedef long long ll;
using namespace std;

bool isprime[maxn];

void prime()  //高效的素数筛法
{
    for (int i=2;i<maxn;i++)
    {
        if (i%2)
            isprime[i]=true;
        else
            isprime[i]=false;
    }
    int m=sqrt(1000010.0);
    for (int i=3;i<m;i++)
    {
        if (isprime[i])
        {
            for (int j=i+i;j<maxn;j+=i)
                isprime[j]=false;
        }
    }
}

int main()
{
    int n;
    while (scanf("%d",&n)&&n)
    {
        int i,a;
        for (i=3;i<n;i++)
        {
            if (isprime[i]&&isprime[n-i])
            {
                a=i;
                break;
            }
        }
        if (i==n)
            printf("Goldbach's conjecture is wrong.\n");
        else
            printf("%d = %d + %d\n",n,a,n-a);
    }
    return 0;
}


posted @ 2014-10-18 21:00  浪子小黄人  阅读(205)  评论(0编辑  收藏  举报