Curling 2.0 (poj 3009 dfs)

Language:
Curling 2.0
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 11954   Accepted: 5061

Description

On Planet MM-21, after their Olympic games this year, curling is getting popular. But the rules are somewhat different from ours. The game is played on an ice game board on which a square mesh is marked. They use only a single stone. The purpose of the game is to lead the stone from the start to the goal with the minimum number of moves.

Fig. 1 shows an example of a game board. Some squares may be occupied with blocks. There are two special squares namely the start and the goal, which are not occupied with blocks. (These two squares are distinct.) Once the stone begins to move, it will proceed until it hits a block. In order to bring the stone to the goal, you may have to stop the stone by hitting it against a block, and throw again.


Fig. 1: Example of board (S: start, G: goal)

The movement of the stone obeys the following rules:

  • At the beginning, the stone stands still at the start square.
  • The movements of the stone are restricted to x and y directions. Diagonal moves are prohibited.
  • When the stone stands still, you can make it moving by throwing it. You may throw it to any direction unless it is blocked immediately(Fig. 2(a)).
  • Once thrown, the stone keeps moving to the same direction until one of the following occurs:
    • The stone hits a block (Fig. 2(b), (c)).
      • The stone stops at the square next to the block it hit.
      • The block disappears.
    • The stone gets out of the board.
      • The game ends in failure.
    • The stone reaches the goal square.
      • The stone stops there and the game ends in success.
  • You cannot throw the stone more than 10 times in a game. If the stone does not reach the goal in 10 moves, the game ends in failure.


Fig. 2: Stone movements

Under the rules, we would like to know whether the stone at the start can reach the goal and, if yes, the minimum number of moves required.

With the initial configuration shown in Fig. 1, 4 moves are required to bring the stone from the start to the goal. The route is shown in Fig. 3(a). Notice when the stone reaches the goal, the board configuration has changed as in Fig. 3(b).


Fig. 3: The solution for Fig. D-1 and the final board configuration

Input

The input is a sequence of datasets. The end of the input is indicated by a line containing two zeros separated by a space. The number of datasets never exceeds 100.

Each dataset is formatted as follows.

the width(=w) and the height(=h) of the board 
First row of the board
 
... 
h-th row of the board

The width and the height of the board satisfy: 2 <= w <= 20, 1 <= h <= 20.

Each line consists of w decimal numbers delimited by a space. The number describes the status of the corresponding square.

0 vacant square
1 block
2 start position
3 goal position

The dataset for Fig. D-1 is as follows:

6 6 
1 0 0 2 1 0 
1 1 0 0 0 0 
0 0 0 0 0 3 
0 0 0 0 0 0 
1 0 0 0 0 1 
0 1 1 1 1 1

Output

For each dataset, print a line having a decimal integer indicating the minimum number of moves along a route from the start to the goal. If there are no such routes, print -1 instead. Each line should not have any character other than this number.

Sample Input

2 1
3 2
6 6
1 0 0 2 1 0
1 1 0 0 0 0
0 0 0 0 0 3
0 0 0 0 0 0
1 0 0 0 0 1
0 1 1 1 1 1
6 1
1 1 2 1 1 3
6 1
1 0 2 1 1 3
12 1
2 0 1 1 1 1 1 1 1 1 1 3
13 1
2 0 1 1 1 1 1 1 1 1 1 1 3
0 0

Sample Output

1
4
-1
4
10
-1

Source

题意:给定一个w*h的地图,0代表空地,1代表障碍,2代表起点,3代表终点,问从起点最少要扔几次才能使冰壶到达终点;冰壶扔出去之后只能沿着一个方向前进,若滑出边界则fail,若撞到障碍则冰壶在与障碍相邻的位置停下且障碍消失,冰壶在一点向某一个方向扔出去的时候,该方向上紧邻的一格不能是障碍。若最小总次数不超过10则输出,否则输出-1.

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <string>
#include <map>
#include <stack>
#include <vector>
#include <set>
#include <queue>
#pragma comment (linker,"/STACK:102400000,102400000")
#define maxn 25
#define MAXN 2005
#define mod 1000000009
#define INF 0x3f3f3f3f
#define pi acos(-1.0)
#define eps 1e-6
typedef long long ll;
using namespace std;

int w,h,sx,sy,ex,ey,minn;
int mp[maxn][maxn];
int dir[4][2]={-1,0,0,1,1,0,0,-1};
bool fail;

bool Isok(int x,int y)
{
    if (x>=0&&x<h&&y>=0&&y<w)
        return true;
    return false;
}

void dfs(int x,int y,int ans)
{
    int dx,dy;
    if (ans>10)
        return ;
    for (int i=0;i<4;i++)
    {
        dx=x+dir[i][0];
        dy=y+dir[i][1];
        if (Isok(dx,dy)&&mp[dx][dy]!=1)  //判断该方向可不可以扔
        {
            do
            {
                if (mp[dx][dy]==3)  //遇到终点
                {
                    if (ans+1<minn)
                    {
                        minn=ans+1;
                        fail=false;
                        return ;
                    }
                }
                dx=dx+dir[i][0];
                dy=dy+dir[i][1];
            }while (Isok(dx,dy)&&mp[dx][dy]!=1);  //向同一个方向走直到遇到障碍停止
        }
        else continue;
        if (dx<0||dx>=h||dy<0||dy>=w)//越界
            continue;
        mp[dx][dy]=0;
        dfs(dx-dir[i][0],dy-dir[i][1],ans+1);
        mp[dx][dy]=1;//回溯
    }
    return ;
}

int main()
{
    while (scanf("%d%d",&w,&h)&&w&&h)
    {
        for (int i=0;i<h;i++)
        {
            for (int j=0;j<w;j++)
            {
                scanf("%d",&mp[i][j]);
                if (mp[i][j]==2)
                {
                    sx=i;sy=j;
                }
                else if (mp[i][j]==3)
                {
                    ex=i;ey=j;
                }
            }
        }
        fail=true;
        minn=INF;
        dfs(sx,sy,0);
        if (fail)
            printf("-1\n");
        else
        {
            if (minn<=10)
                printf("%d\n",minn);
            else
                printf("-1\n");
        }
    }
    return 0;
}



posted @ 2014-10-19 21:36  浪子小黄人  阅读(177)  评论(0编辑  收藏  举报