Agri-Net (poj 1258 最短路+prim)

Language:
Agri-Net
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 40905   Accepted: 16682

Description

Farmer John has been elected mayor of his town! One of his campaign promises was to bring internet connectivity to all farms in the area. He needs your help, of course. 
Farmer John ordered a high speed connection for his farm and is going to share his connectivity with the other farmers. To minimize cost, he wants to lay the minimum amount of optical fiber to connect his farm to all the other farms. 
Given a list of how much fiber it takes to connect each pair of farms, you must find the minimum amount of fiber needed to connect them all together. Each farm must connect to some other farm such that a packet can flow from any one farm to any other farm. 
The distance between any two farms will not exceed 100,000. 

Input

The input includes several cases. For each case, the first line contains the number of farms, N (3 <= N <= 100). The following lines contain the N x N conectivity matrix, where each element shows the distance from on farm to another. Logically, they are N lines of N space-separated integers. Physically, they are limited in length to 80 characters, so some lines continue onto others. Of course, the diagonal will be 0, since the distance from farm i to itself is not interesting for this problem.

Output

For each case, output a single integer length that is the sum of the minimum length of fiber required to connect the entire set of farms.

Sample Input

4
0 4 9 21
4 0 8 17
9 8 0 16
21 17 16 0

Sample Output

28

Source

模板题,直接套模板。。。

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <string>
#include <map>
#include <stack>
#include <vector>
#include <set>
#include <queue>
#pragma comment (linker,"/STACK:102400000,102400000")
#define maxn 105
#define MAXN 2005
#define mod 1000000009
#define INF 0x3f3f3f3f
#define pi acos(-1.0)
#define eps 1e-6
typedef long long ll;
using namespace std;

int N;
int mp[maxn][maxn],visit[maxn],dist[maxn];

void prim()
{
    int i,j,mi,now;
    memset(visit,0,sizeof(visit));
    memset(dist,INF,sizeof(dist));
    for (i=0;i<N;i++)
        dist[i]=mp[0][i];
    dist[0]=0;
    visit[0]=1;
    for (i=0;i<N;i++)
    {
        mi=INF;
        now=-1;
        for (j=0;j<N;j++)
        {
            if (!visit[j]&&dist[j]<mi)
            {
                mi=dist[j];
                now=j;
            }
        }
        if (now==-1)
            break;
        visit[now]=-1;
        for (j=0;j<N;j++)
            if (!visit[j]&&dist[j]>mp[now][j])
                dist[j]=mp[now][j];
    }
    int ans=0;
    for (i=0;i<N;i++)
        ans+=dist[i];
    printf("%d\n",ans);
}

int main()
{
    while (scanf("%d",&N)!=EOF)
    {
        for (int i=0;i<N;i++)
        {
            for (int j=0;j<N;j++)
                scanf("%d",&mp[i][j]);
        }
        prim();
    }
    return 0;
}
/*
4
0 4 9 21
4 0 8 17
9 8 0 16
21 17 16 0
*/




posted @ 2014-10-19 23:32  浪子小黄人  阅读(139)  评论(0编辑  收藏  举报