Dirichlet's Theorem on Arithmetic Progressions (poj 3009 水题)

Language:
Dirichlet's Theorem on Arithmetic Progressions
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 15961   Accepted: 8016

Description

If a and d are relatively prime positive integers, the arithmetic sequence beginning with a and increasing by d, i.e., aa + da + 2da + 3da + 4d, ..., contains infinitely many prime numbers. This fact is known as Dirichlet's Theorem on Arithmetic Progressions, which had been conjectured by Johann Carl Friedrich Gauss (1777 - 1855) and was proved by Johann Peter Gustav Lejeune Dirichlet (1805 - 1859) in 1837.

For example, the arithmetic sequence beginning with 2 and increasing by 3, i.e.,

2, 5, 8, 11, 14, 17, 20, 23, 26, 29, 32, 35, 38, 41, 44, 47, 50, 53, 56, 59, 62, 65, 68, 71, 74, 77, 80, 83, 86, 89, 92, 95, 98, ... ,

contains infinitely many prime numbers

2, 5, 11, 17, 23, 29, 41, 47, 53, 59, 71, 83, 89, ... .

Your mission, should you decide to accept it, is to write a program to find the nth prime number in this arithmetic sequence for given positive integers ad, and n.

Input

The input is a sequence of datasets. A dataset is a line containing three positive integers ad, and n separated by a space. a and d are relatively prime. You may assume a <= 9307, d <= 346, and n <= 210.

The end of the input is indicated by a line containing three zeros separated by a space. It is not a dataset.

Output

The output should be composed of as many lines as the number of the input datasets. Each line should contain a single integer and should never contain extra characters.

The output integer corresponding to a dataset adn should be the nth prime number among those contained in the arithmetic sequence beginning with a and increasing by d.

FYI, it is known that the result is always less than 106 (one million) under this input condition.

Sample Input

367 186 151
179 10 203
271 37 39
103 230 1
27 104 185
253 50 85
1 1 1
9075 337 210
307 24 79
331 221 177
259 170 40
269 58 102
0 0 0

Sample Output

92809
6709
12037
103
93523
14503
2
899429
5107
412717
22699
25673

Source

题意:设一个等差数列,首元素为a,公差为d,现在要求输入a,b,n ,要求找出属于该等差数列中的第n个素数并输

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <string>
#include <map>
#include <stack>
#include <vector>
#include <set>
#include <queue>
#pragma comment (linker,"/STACK:102400000,102400000")
#define maxn 1000005
#define MAXN 2005
#define mod 1000000009
#define INF 0x3f3f3f3f
#define pi acos(-1.0)
#define eps 1e-6
typedef long long ll;
using namespace std;

bool Isprime[maxn];

void prime()
{
    for (int i=2;i<maxn;i++)
    {
        if (i%2)
            Isprime[i]=true;
        else
            Isprime[i]=false;
    }
    Isprime[2]=true;
    int m=sqrt(1000005.0);
    for (int i=2;i<m;i++)
    {
        if (Isprime[i])
        {
            for (int j=i+i;j<maxn;j+=i)
                Isprime[j]=false;
        }
    }
}

int main()
{
    prime();
    int a,d,n;
    while (scanf("%d%d%d",&a,&d,&n)&&a&&d&&n)
    {
        int x=0;
        while (x<n)
        {
            if (Isprime[a])
                x++;
            a+=d;
        }
        printf("%d\n",a-d);
    }
    return 0;
}


posted @ 2014-10-20 23:19  浪子小黄人  阅读(176)  评论(0编辑  收藏  举报