MySQL 服务无法启动。 服务没有报告任何错误。

在MySQL目录中新建data空文件夹,将my.ini中修改

datadir=data路径

比如我的修改如下:

data空文件夹路径:

my.ini中datadir的值修改为

 保存后以管理员的身份运行cmd,且cd至bin目录下

运行命令  mysqld --initialize-insecure  ,运行过程中可见data文件夹自动生成一些必要的文件,稍等片刻运行完毕后即可运行 net start mysql.

至此结束。

posted @ 2018-10-17 23:53  袖白、  阅读(3410)  评论(0)    收藏  举报