Confluence 6 升级 Confluence 使用数据源

如果你对 Confluence 进行升级(手动或者使用安装器),你需要:

  • 停止 Confluence (如果你已经尝试开始启动)。
  • 拷贝你的数据库驱动到 <installation-directory>/lib 目录。
  • 编辑 <installation-directory>/conf/server.xml 同时添加你的数据源资源。
  • 编辑 <installation-directory>/confluence/WEB-INF/web.xml 到配置 Confluence 使用数据源。

如果你忘记进行这些步骤,Confluence 将会在你升级完成后停止启动,并且你将会看到下面的错误信息:

HTTP Status 500 - Confluence is vacant, a call to tenanted [public abstract org.hibernate.Session org.hibernate.SessionFactory.getCurrentSession() throws org.hibernate.HibernateException] is not allowed.

 

https://www.cwiki.us/display/CONFLUENCEWIKI/Configuring+a+datasource+connection

posted @ 2018-06-08 22:40  huyuchengus  阅读(212)  评论(0编辑  收藏