代码改变世界

Linux下安装Gensim

2018-10-22 10:59  猎手家园  阅读(2344)  评论(0编辑  收藏  举报

依赖软件包:numpy

直接使用pip安装:

[root@mycentos ~]#pip install gensim

 

安装gensim的时候会遇到下面的一系列错误:

Cannot uninstall 'numpy'. It is a distutils installed project and thus we cannot accurate

意思是:

安装gensim的时候需要numpy更高的版本,而自带的numpy版本较低,版本有问题但是numpy已经安装过了,无法进行直接卸载。
解决办法:强行安装更新更高的版本。

[root@mycentos ~]#pip install numpy --ignore-installed numpy
[root@mycentos ~]#pip install scipy --ignore-installed scipy

 其它软件同理。