hdu 1005

Problem Description
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).
 

 

Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
 

 

Output
For each test case, print the value of f(n) on a single line.
 

 

Sample Input
1 1 3
1 2 10
0 0 0
 

 

Sample Output
2
5
 
 
不可以用递归公式求  会溢出 因为n比较大  (尽管我也是看见别人的博客才知道的)
 
对于公式 f[n] = A * f[n-1] + B * f[n-2]; 后者只有7 * 7 = 49 种可能,为什么这么说,因为对于f[n-1] 或者 f[n-2] 的取值只有 0,1,2,3,4,5,6 这7个数,A,B又是固定的,所以就只有49种可能值了。由该关系式得知每一项只与前两项发生关系,所以当连续的两项在前面出现过循环节出现了,注意循环节并不一定会是开始的 1,1 。 又因为一组测试数据中f[n]只有49中可能的答案,最坏的情况是所有的情况都遇到了,那么那也会在50次运算中产生循环节。找到循环节后,就可以轻松解决了。(贴过来的)
 
代码如下    (但是我提交了N次,只要i《=10000,就出现运行错误)......      求指点
#include <stdio.h>
#include <math.h>
int f[10000];
int main()
{
    int a,b,n,i;
    f[1]=1;
    f[2]=1;
    while(scanf("%d%d%d",&a,&b,&n),a|b|n)
    {
        for(i=3; i<10000; i++)
        {
            f[i]=(a*f[i-1]+b*f[i-2])%7;
            if(f[i]==1&&f[i-1]==1)
            {
                break;
            }
        }
        n=n%(i-2);
        f[0]=f[i-2];
        printf("%d\n",f[n]);
    }
    return 0;
}

 

posted @ 2016-05-19 23:00  果冻0_0  阅读(236)  评论(0编辑  收藏  举报