Live2d Test Env

POJ2891Strange Way to Express Integers (线性同余方程组)

Elina is reading a book written by Rujia Liu, which introduces a strange way to express non-negative integers. The way is described as following:

 

Choose k different positive integers a1a2…, ak. For some non-negative m, divide it by every ai (1 ≤ i ≤ k) to find the remainder ri. If a1a2, …, ak are properly chosen, m can be determined, then the pairs (airi) can be used to express m.

“It is easy to calculate the pairs from m, ” said Elina. “But how can I find m from the pairs?”

Since Elina is new to programming, this problem is too difficult for her. Can you help her?

Input

The input contains multiple test cases. Each test cases consists of some lines.

  • Line 1: Contains the integer k.
  • Lines 2 ~ k + 1: Each contains a pair of integers airi (1 ≤ i ≤ k).

 

Output

Output the non-negative integer m on a separate line for each test case. If there are multiple possible values, output the smallest one. If there are no possible values, output -1.

 

Sample Input

2
8 7
11 9

Sample Output

31

Hint

All integers in the input and the output are non-negative and can be represented by 64-bit integral types.

线性同余方程组,终于自己写了一遍。棒棒哒。

 

#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<cmath>
#include<iostream>
#define ll long long
using namespace std;
void Ex_gcd(ll a,ll b,ll &d,ll &x,ll &y)
{
    if(b==0){ d=a; x=1; y=0; return ;}
    Ex_gcd(b,a%b,d,y,x); y-=a/b*x;
}
int main()
{
    ll c1,c2,c,a,b,d,x,y,n;
    while(~scanf("%lld",&n)){
        bool Flag=false;
        scanf("%lld%lld",&a,&c1);
        for(int i=2;i<=n;i++) {
            scanf("%lld%lld",&b,&c2); 
            if(Flag) continue; c=c2-c1;
            Ex_gcd(a,b,d,x,y);
            if(c%d!=0) { printf("-1\n"); Flag=true;}
            x=((c/d*x)%(b/d)+b/d)%(b/d);//最小正单元 
            c1=a*x+c1;a=a*b/d;
        }    
        if(!Flag) printf("%lld\n",c1);
    }   return 0;
}

 

posted @ 2017-12-17 19:12  nimphy  阅读(226)  评论(0编辑  收藏  举报