Live2d Test Env

POJ3311Hie with the Pie(floyd传递+DP,状态压缩)

问题

The Pizazz Pizzeria prides itself in delivering pizzas to its customers as fast as possible. Unfortunately, due to cutbacks, they can afford to hire only one driver to do the deliveries. He will wait for 1 or more (up to 10) orders to be processed before he starts any deliveries. Needless to say, he would like to take the shortest route in delivering these goodies and returning to the pizzeria, even if it means passing the same location(s) or the pizzeria more than once on the way. He has commissioned you to write a program to help him.

Input

Input will consist of multiple test cases. The first line will contain a single integer n indicating the number of orders to deliver, where 1 ≤ n ≤ 10. After this will be n + 1 lines each containing n + 1 integers indicating the times to travel between the pizzeria (numbered 0) and the n locations (numbers 1 to n). The jth value on the ith line indicates the time to go directly from location i to location j without visiting any other locations along the way. Note that there may be quicker ways to go from i to j via other locations, due to different speed limits, traffic lights, etc. Also, the time values may not be symmetric, i.e., the time to go directly from location i to j may not be the same as the time to go directly from location j to i. An input value of n = 0 will terminate input.

Output

For each test case, you should output a single number indicating the minimum time to deliver all of the pizzas and return to the pizzeria.

Sample Input

3
0 1 10 10
1 0 1 2
10 1 0 10
10 2 10 0
0

Sample Output

8

 

  • floyd闭包传递。
  • 之前做过差不多的题,主要是保存以及访问过的和目前停止的地方。
  • 需要强制起点为0。
#include<cstdio>
#include<cstdlib>
#include<iostream>
#include<algorithm>
#include<cmath>
#include<cstring>
using namespace std;
const int inf=1000000000;
int dp[3000][20],dis[20][20],n,ans;
void floyd()
{
    for(int k=0;k<=n;k++)
      for(int i=0;i<=n;i++)
        for(int j=0;j<=n;j++)
         dis[i][j]=min(dis[i][j],dis[i][k]+dis[k][j]);
}
void getdp()
{
    for(int i=0;i<(1<<(n+1));i++){
        for(int j=0;j<=n;j++){
            if(i&(1<<j)){
                if(i==(1<<j)) dp[i][j]=dis[0][j];
                else{
                    dp[i][j]=inf;
                    for(int k=0;k<=n;k++)
                    if((i&(1<<k)&&k!=j))
                    dp[i][j]=min(dp[i][j],dp[i^(1<<j)][k]+dis[k][j]);    
                }
            }
        }
    }
}
int main()
{
    int i,j,k;
    while(~scanf("%d",&n)){
        if(n==0) return 0;
        for(i=0;i<=n;i++)
         for(j=0;j<=n;j++)
          scanf("%d",&dis[i][j]);
        
        floyd(); getdp(); ans=inf;
        for(i=1;i<=n;i++)  ans=min(ans,dp[(1<<(n+1))-1][i]+dis[i][0]);
        printf("%d\n",ans);
    }
    return 0;
}

 

posted @ 2017-12-03 15:24  nimphy  阅读(244)  评论(0编辑  收藏  举报