Live2d Test Env

zoj 1874 水题,输出格式大坑

Primary Arithmetic

Time Limit: 2 Seconds      Memory Limit: 65536 KB

Children are taught to add multi-digit numbers from right-to-left one digit at a time. Many find the "carry" operation - in which a 1 is carried from one digit position to be added to the next - to be a significant challenge. Your job is to count the number of carry operations for each of a set of addition problems so that educators may assess their difficulty.


Input

Each line of input contains two unsigned integers less than 10 digits. The last line of input contains 0 0.


Output

For each line of input except the last you should compute and print the number of carry operations that would result from adding the two numbers, in the format shown below.


Sample Input

123 456
555 555
123 594
0 0


Sample Output

No carry operation.
3 carry operations.
1 carry operation.


题目没什么难度,唯一值得我写的就是:假如我的同桌是小明,他的作文里有10处错误。

(单复数,woc)。233333333333333333333333

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<memory.h>
#include<math.h> 
using namespace std;
int a[12],b[12];
int main()
{
	int x,y;
	while(cin>>x>>y)
	{   
		if(x==0&&y==0) return 0;
		for(int i=1;i<12;i++) a[i]=b[i]=0;
		int L1=0,L2=0,ans=0;
		while(x!=0){
			a[++L1]=x%10;
			x/=10;
		}
		while(y!=0){
			b[++L2]=y%10;
			y/=10;
		}
		for(int i=1;i<=10;i++)
		{
			a[i]=a[i]+b[i];
			if(a[i]>=10) ans++;
			a[i+1]+=a[i]/10;
		}
		if(ans==0) printf("No carry operation.\n");
		else if(ans==1) printf("1 carry operation.\n",ans);
		else printf("%d carry operations.\n",ans);
	}
}


posted @ 2017-09-27 21:06  nimphy  阅读(253)  评论(0编辑  收藏  举报