Dancing Stars on Me

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 286    Accepted Submission(s): 185


Problem Description
The sky was brushed clean by the wind and the stars were cold in a black sky. What a wonderful night. You observed that, sometimes the stars can form a regular polygon in the sky if we connect them properly. You want to record these moments by your smart camera. Of course, you cannot stay awake all night for capturing. So you decide to write a program running on the smart camera to check whether the stars can form a regular polygon and capture these moments automatically.

Formally, a regular polygon is a convex polygon whose angles are all equal and all its sides have the same length. The area of a regular polygon must be nonzero. We say the stars can form a regular polygon if they are exactly the vertices of some regular polygon. To simplify the problem, we project the sky to a two-dimensional plane here, and you just need to check whether the stars can form a regular polygon in this plane.
 

 

Input
The first line contains a integer T indicating the total number of test cases. Each test case begins with an integer n , denoting the number of stars in the sky. Following n lines, each contains 2 integers xi,yi , describe the coordinates of n stars.

1T300
3n100
10000xi,yi10000
All coordinates are distinct.
 

 

Output
For each test case, please output "`YES`" if the stars can form a regular polygon. Otherwise, output "`NO`" (both without quotes).
 

 

Sample Input
3 3 0 0 1 1 1 0 4 0 0 0 1 1 0 1 1 5 0 0 0 1 0 2 2 2 2 0
 

 

Sample Output
NO YES NO
 

 

Source
题意:t 组数组 给你n个点  接着n组坐标(必须是整数)orzzz  判断 能否组成正多边形!!
 
题意说是每个点都是整数  说明只有正方形 才能满足
 
学长讲了之后 现在补  就是简单的判断 4个点能否组成正方形
 
GG 一次过了
判断 四边是否相等 并且判断一个直角
判断之前 有一个排序过程
 
bool cmp(struct node a,struct node b)
{
    if(a.x>b.x)
        return true;
    if(a.x==b.x)
    {
        if(a.y>b.y)
            return true;
    }
    return false;
}
 
 
#include<bits/stdc++.h>
using namespace std;
int t;
int n;
struct node
{
    double x;
    double y;
}N[105];
double dis(int x1,int y1,int x2,int y2)
{
    return sqrt((x1-x2)*(x1-x2)+(y1-y2)*(y1-y2));
}
bool cmp(struct node a,struct node b)
{
    if(a.x>b.x)
        return true;
    if(a.x==b.x)
    {
        if(a.y>b.y)
            return true;
    }
    return false;
}
int main()
{
    scanf("%d",&t);
    for(int i=1;i<=t;i++)
    {
        memset(N,0,sizeof(N));
        scanf("%d",&n);
        for(int j=0;j<n;j++)
            scanf("%lf%lf",&N[j].x,&N[j].y);
        if(n!=4)
            printf("NO\n");
        else
        {
            sort(N,N+4,cmp);
            int dis1,dis2,dis3,dis4,ss1,ss2,ss3;
            dis1=dis(N[0].x,N[0].y,N[1].x,N[1].y);
            dis2=dis(N[2].x,N[2].y,N[3].x,N[3].y);
            dis3=dis(N[0].x,N[0].y,N[2].x,N[2].y);
            dis4=dis(N[1].x,N[1].y,N[3].x,N[3].y);
             ss1=(N[0].x-N[1].x)*(N[0].x-N[1].x)+(N[0].y-N[1].y)*(N[0].y-N[1].y);
             ss2=(N[0].x-N[2].x)*(N[0].x-N[2].x)+(N[0].y-N[2].y)*(N[0].y-N[2].y);
             ss3=(N[1].x-N[2].x)*(N[1].x-N[2].x)+(N[1].y-N[2].y)*(N[1].y-N[2].y);
            if(dis1==dis2&&dis2==dis3&&dis3==dis4&&((ss1+ss2)==ss3))
                printf("YES\n");
            else
                printf("NO\n");
           }
    }

    return 0;
}